0xc000007b launching issue

Hello,

Just like other users, I can’t open the game after it is installed: I receive the « 0xc000007b » error message. (A detail that is perhaps of importance: even though I tick that option at the end of the install, the computer is not moving a Democracy 4 icon to the desktop - but it is accessible normally through the Windows search bar).

Most users facing this issue seem to have been able to solve it by switching their antivirus software off… But my PC doesn’t have one, except for the standard Windows security features (I borrowed the PC just to play that game).

I also tried reinstalling various versions of the Microsoft Visual C++… A user mentioned that using the 32 bit one worked out for him - but it seems Microsoft doesn’t make that version available anymore on their website.

Please let me know what I could try doing to solve this issue…

Thanks a lot, best,

Samuel

1 Like

Another user also mentioned installing it through Steam. I bought it through Humble Bundle, and paired my Humble Bundle account with a new Steam account I created for the occasion - but the game doesn’t show on my Steam account, whether I’m using the browser or the Steam app.

1 Like

@cliffski

Hi again,

Would there be any update on the nature of the problem i might be facing…?

Thanks!

1 Like