[1.24] Crash On StartUP


#1

Hi, I also posted about this in the impulse forums, but thought i’d post it here as well, as it was more likely to do some good on the official forums. Since updating to 1.24 the game now crashes on startup. It gets to the Red Menu screen before immeditately putting up the default “GSB.exe has stopped working” error message. As a side note, I have also updated my graphics drivers reciently (ie, since I last ran the game), so that might have something to do with it. Unfortunately, I really don’t want to roll the drivers back, as then l4d2 won’t work.

Below I’ve given as much info as I found easily available - if there is anything more I’ll be happy to help.

:slight_smile:

Specs:

Debug.txt:

DrawDebug.txt:


#2

did it work before you updated to 1.24?


#3

Yes, sorry if I didn’t make that clear. Yes, it has worked before I updated although the last time I tried running it was a month or so back, and that was also before I updated my graphics drivers.

Edit - ps. If I also didn’t make clear - I bought the game via impulse and used impulse’s system to update the game, if that makes any difference.

:slight_smile:


#4

I suspect this is not graphics related at all. It looks like the game actually starts up the graphics engine just fine, and must be choking somewhere else.
I recommend a total uninstall and re-download, with all the folders renamed first, to ensure that there is no way a corrupt file, a modded file, or a mis-applied patch could eb causing problems. If it then runs, hurrah! If not, it could theoretically be driver related, and you can verify that easily by swapping back temporarily. Failing that, it could be some other windows issue, so you could go back a restore point. Failing that, I’d have to suggest doing the good old spyware / virus check and defrag in case you actually have malware or some disk issue, but thats all getting increasingly unlikely.


#5

Cheers for your fast responce (and sorry for my slow one).

After trying a couple of things, I ended up doing a re-install and that fixed the problem. When I uninstalled tho, it left the folder C:\Users\Luke\Documents\My Games\GratuitousSpaceBattles, so I renamed it so it wouldn’t get in the way when I re-installed. Being a nosy sod, I then went and had a quick compare of the stuff that was in the new GratuitousSpaceBattles folder and the old one. The big difference seemed to be that in the old folder, config.txt & tutorial_seen.ini were completely empty. Now, i guess that they could have been cleared during the uninstall, but its a bit weird that it would clear them and not delete them, and also leave things like the deployment files intact.

Anyway, I guess not having a valid config.txt file could have easily explained the crash?

Anyway, it seems to work now, so all is good again.

Ta

:slight_smile: