1.29 Mac: Game crashes on single player battle start


#1

GSB v1.29
for Mac OS X 10.10.3
purchased through gog.com

I read the official ‘being worked on’ post, but couldn’t tell if this was covered by it or not. So for completeness’ sake, I want to report a crash bug everytime I try to start a battle on Malvastaxx Alpha.

Almost immediately the game crashes after loading everything. The first time I fired it up it seemed to get about 30 seconds in before crashing, but since then its been almost instant every time.

In case its useful, here’s the crash report spec info given to me by the os afterwards:

Am not holding out much hope as when I tried to register with your forum I found that I couldn’t receive your activation email, and the only solution I could find was to ‘message an admin’ which I couldn’t figure out how to do when not registered. I eventually found that someone else posted about the same problem here:
http://positech.co.uk/forums/phpBB3/viewtopic.php?f=4&t=7935&p=61798&hilit=activation+email#p61798
back in 2013, (I’m also using a hotmail email address. I’ve since registered with another one), and there’s obviously not been a fix implemented or even a reply posted to their problem.


#2

silversurfer20,

Greetings!
Exactly which version number of GSB2 are you playing?
Is it correct that you’re playing a non-Steam, Mac version of the game? Please confirm.
These data are very important to know before any troubleshooting of this crash can begin.
Please review the clearly-labeled announcement link at the very top of this forum to see what’s required in a Support request.


#3

Sorry, I naively assumed that info would be in the crash report, but I see its not actually terribly helpful :slight_smile: Its version 1.29, and yes its on mac OS 10.10.3, purchased through gog.com.


#4

Thank you. That additional info is a big help for the game developer. :wink:
I’ll now edit the subject line for the thread as a whole, as well as the body of your first post herein.