[1.40 Steam] Crash on Launch w/ Missing "My Games" Data

System info:

Win 7 Home Premium SP 1 64 bit (6.1 Build 7601)
GTX 590, i7 2600k 3.5GHz 8 Core, 16GB RAM.

Current application error: “The application was unable to start correctly (0xc000007b). Click OK to close the application.”

There is no obvious error log left in the local files.

My desktop is laid out unsually, with seperate partitions for major functions, such as a data partition, os partition etc. I think this might be why I can’t find - and suspect the game might have failed to create one resulting in the crash on startup.

Initially, I encountered the d3dx9_41.dll not found error - now fixed, but the game will still not start. Looking at another discussion regarding crashing essentially prelaunch, I tried to find the GratuitousSpaceBattles2 folder in My Games, but I think the complex partition system may have confused the game at install and I cannot for the life of me find it. Are there any ways I can:
a) find it or
b) get it to create one for itself that isn’t somewhere it can’t find.


Probably the game is finding difficulties to use your current desktop resolution or there is a graphic problem somewhere, i dont think it has something to do with your hard drive, partitions or watever.

Did you try to change the resolution?

On a sidenote, the game is too glitchy in a lot of aspects, and unfortunately the development of the game stopped a long time ago. So, if the problem is related to the game itself, you are out of luck since it will never be fixed. My advise will be that you return to GSB1.