Aegis Democracy 3 Mod Editor v0.25


#1

How much do you like the Policy-Userinterface in v0.25

  • It’s a great interface
  • It’s ok but it can be better
  • Too much controls, aaargh
  • The worst user interface I have ever seen

0 voters

This Editor is not supported anymore.


#2

List of known Issues:

  • FileOpen/Save - Dialogs don’t remember the last directory – v0.25 most dialogs remember last directory now, a few are missing this feature
  • Load Mod: Country: only finds country file if country-filename = mod name
  • Load Mod: Country: a few policies show a red border
  • Load Mod/Load Country: doesn’t load the compass file
  • Save Policy only saves policies file, no icons -> but working with “Save All”
  • Sometimes there’s an error message on loading a mod, but everything is loaded fine
  • Load Mod/Load country: Is not setting the Image pathes
  • Load additional Effects: After loading all effects of the policy are set to “NO EFFECT”, but if navigating back and forward, it shows correct again
  • Currently no “*_cost” parameters are supported
  • Mod Path & names file must be set relative to Democracy3 directory. A mod path like “C:\mymod” is not working
  • If leaving Mod Path empty, the tool asks you if you want to delete the Democracy3 directory. Say “No” in that case. -> thx to ruzen for reporting
    -> Will do a check that Mod Path needs to be filled, so this can’t happen again.

Solved known issues:

  • If there are only a few effects and no ending ‘,’ -> the last effect is loaded into all effects that are unused -> fixed with v0.25
  • € sign is not correctly loaded and when saved with the editor it doesn’t show up ingame -> fixed with v0.25
  • Values are not saved correctly, when using ‘.’ (dot) instead of ‘,’ comma, makes 4 out of 0.04 -> thx to IntruderEmerald for reporting -> fixed with v0.25
  • Cost Multiplier is not loaded or not shown -> thx to Thimorin for reporting -> fixed with V0.25
  • Second Value & “No Second Value” is sometimes not saved in complex formulas -> fixed with V0.21
  • Country -> Policies-List: If there is an item selected in the list, and a different one in the combobox, both policies get updated when changing the value -> fixed with V0.21
  • Need to add a scrollbar, so it supports lower resolutions -> Thanks to SaGeOwL for reporting -> fixed with V0.21
  • Countries saved that are not using all stats, can’t be loaded anymore in the editor -> fixed with V0.21
  • Deleting the last policy leads to Mod Editor Crash -> fixed with v0.21

#3

This is great… need to pass through the learning curve but it is understandable, thanks.

Got only a problem with my screen resolution… maybe you can add a slide bar to scroll down, 'cause the last line is barely visible to me.


#4

Good to tell me.
I’m working now on a Version 0.21 including a scrollbar and some fixes for the minor issues.
If tests run fine, I think I could release it this evening.


#5

I’m watching development of this. I downloaded it and tried to use it, but I don’t feel I can do anything very interesting without simulation and situation modding.


#6

It will take quite some time, till simulation and situations getting done with my editor.

I currently work on redesigning code and make it all a better user experience.
(instead of stupid msg-boxes for every input field, I want to mark them green/red depending
if they are correct/incorrect)

Next then is a Mod-Tab, which should be able to load all parts from a mod that are currently
implemented by simply opening the Mod-File.
And there should be a “Save all”, to save a complete mod structure.

I think it’s about a week, till I can release v0.30, Situations are planned for v.40,
Simulations v.50 (you could currently use Khornels tool for Simulations)


#7

So, I close the program come back after playing and the effects are 4 instead of 0.04?

Great mod editor btw, I’ll be using it alot! :smiley:


#8

This is really awesome, it’s great to see something like this has been made.
If you bundle this up using inno setup and use AppName=Democracy 3 in the setup script, it will install into the same folder as the game, and then you could be sure you know the relative path to all the folders.
just an idea :smiley:


#9

Hi IntruderEmerald,

Do you have a file where this happens, so I can look what I’m doing wrong?
Or you know when this happens, cause that’s an error for sure.

Thx, this is water on my mill, I’m sure when you like v0.21 you will love v0.25, which will come in a few days.
(probably Tuesday or Wednesday, depending if everything runs fine)

Regards,

Aegis


#10

So, if I add a policy then save it and leave the mod editor running while I test it and then come back the effects stay the same. However, if I close the program and open it the effects have changed. For example 0.04 becomes 4. It’s happening on all the policies I add.


#11

This happens when using ‘.’ as separator instead of ‘,’.
I will fix that till next release, actually better use comma.


#12

Ok. I just tried it and I put 0,04 but it still thinks that is 4


#13

Use System.Globalization.CultureInfo.InvariantCulture to force . Decimal notation on any computer.


#14

Thx for the tip, i don’t know the Framework as good as you, it seems.
But if I force . notation, doesn’t that mean, that , is not allowed anymore?
Want to have both notation, so everyone can use . or , how they are used to in there notation.


#15

You could do that, just make sure you use invariantculture when converting numbers to strings so democracy can read it. E.g. I use Convert.ToDouble (string, invariantculture) and double.ToString (invariantculture).
I don’t know if .Net supports both in anyway, you’ll have to use regex or something yourself because of cases like 100.000,00


#16

Yea, already thought today of cases like 100.000,00 or 100,000.00, they are currently not supported, but is planned for v0.25.
When saving I convert everything to Democracy 3 format, so entered is a , but I save it with . so that democracy is working.


#17

I’ve tried installing this as it looks really helpful but everytime I change the path it just says that it either cant be found or “the given path’s format is not supported” any help??

Thank you


#18

Hello jshipley,

is this message happening on startup or when you use a Open/Save Dialog?

Did you change the config.txt file, to reflect your installation, and if so, could you link the [pathes] section?


#19

Erm, it happens when I try to install it! I did, I tried it with several different ones and it didn’t work. Should it be directed to the programfiles/democracy3 folder or should it be the one in my documents? I’ve tried both and neither seemed to work, maybe I’m putting it in wrong?


#20

Generally you can install it in the folder of your choice, you can also put all the files into your Democracy 3 Folder.
Place all the files in the same directory, the files inside the zip archive are:
“Aegis Democracy 3 Mod Editor.exe”, “Config.txt”, “licence.txt” and “Version History.txt”

Let’s try it with this step by step guide:

  1. Download AegisD3ModEditor_v021.zip (You could skip step 1+2, if you have saved the zip)
  2. Say “Save as” and download it
  3. Double Click the downloaded archive (AegisD3ModEditor_v021.zip)
  4. Open a windows explorer with the path of your Democracy install
  5. Drag and Drop all the files from the archive into your democracy 3 folder
  6. Open the file “Config.txt”
  7. Change the [pathes] section to the following
# Change the pathes so they fit to your Democracy 3 Installation
[pathes]
filepath_democracy3 = ".\"
filepath_policies = ".\data\simulation\policies.csv"
filepath_sliders =".\data\simulation\sliders.csv"
filepath_departments = ".\data\simulation\policygroups.csv"
filepath_votertypes = ".\data\simulation\votertypes.csv"
filepath_simulation = ".\data\simulation\simulation.csv"
filepath_situations = ".\data\simulation\situations.csv"

(don’t remove the other parts inside the config, they are necessary.
8) Save the Config file
9) Start “Aegis Democracy 3 Mod Editor.exe”

Hope that’s some help with your installation issues.