After unlocking items in fleet HQ... they are locked


#1

I got the new update and I installed it correctly. Then when ever I buy another item, it stays locked.
Any advice?


#2

what happens? does the honor get spent? have you ever unlocked anything succesfully? Is the game saving your other settings (your username, screen resolution etc) ok?


#3

Yes, everything else saves fine in options and completed missions. I have bought items before (maybe 2 months ago) and they were unlocked just fine. Now, nothing I buy becomes unlocked. It says the items are when I go to the fleet HQ but they still have a lock on them and I cannot equip them to ships in the ship design. The honor also gets spent up.


#4

It sounds like the game cannot write to this file:

\my documents\my games\gratuitous space battles\unl.dat

it might be worth checking that somehow that file has not become corrupt, or set to read-only.
Failing that, it could be somehow a corrupt installation of the game, so you ciould try re-downloading the full game installer and running that, rather than any patches.


#5

Well, that file is not read only, and I even ran an integrity check and steam got the files that were corrupt or gone. The items were still not unlocked so I uninstalled the game and am reinstalling it now.

after I reinstalled…
I just checked and the items were still locked but it says “unlocked” at the fleet hq. Another odd thing is, I bought ultraheavy cruiser armor and a nuke launcher but the armor is unlocked even though I bought both at the same time.


#6

Thats very strange, either the file shouldnt be writable or it should be, if shouldn’t happen occasionally like that. Do fresh unlocks now work? maybe reinstalling has fixed it from this point on?


#7

So I bought a Cruiser Proton Beam and it is available to be used but the turbo shields and the nuclear missile launcher are still locked.


#8

Also check to see if you have unl.dat located in:

C:\Program Files\Gratuitous Space Battles\userdir\GratuitousSpaceBattles

You can also open unl.dat file using Notepad and unlock them manually.


#9

Are you sure this isn’t just a case of certain modules not being allowed on certain races’ ships?

Nuclear missile launcher for example cannot be put on a Federation ship.


#10

I also own the empire and that and the turbo shields are still locked

I’ll check that file