All text appears jumbled

After using the game several times in the past few days I did a restart to install some unrelated software (word processing app). Now every time I start the game all text with the exception of logo images appear jumbled and compressed. I turned off the DLC i recently installed (as far as I could tell, It’s kinda hard when you can’t read what things are) and as a Mac user i don’t have any mods, you all haven’t gotten around to supporting those for us yet so that wasn’t an issue. Tried another restart, problem remains. Tried restarting the steam client, problem remains.

OSX 10.7.5
MacBook Pro mid 2010 model
NVIDIA GeForce GT 330M 512 MB

Same problem here… just happened in the past 4 hours actually - no changes or mods made to my system. Running i7 server w/ Mavericks.

Same thing for me. It was working perfectly and now the text is all messed up.

Same here… didn’t happen until I downloaded the new update that fixes the equality-crime relationship. I’m also on a mac…

I just deleted steam and re-installed and then re-downloaded democracy 3 and everything works fine now. For those of you who have a lot of games, this might suck to have to re-download all your games again. I only had this game, so it wasn’t a big deal for me. I own a Mac and this is pretty much the only worthwhile game I’ve found to buy on steam, heh.

Edit: I think it’s important to note that I didn’t lose any of my saves, progress or achievements by re-installing.

thanks awol… it’s a small PITA… but I hate silly bugs like this.

all text is messed up. reinstalled Steam and still the same result. not happy. played the game for about 10-12 hours total and then this happens. please help!!


I also have an IMac…(note previous post)

Hi, we just reverted the latest patch for mac until we sort this out…sorry about this…

it’s all good now again…I’m on IMac through Steam

Everything’s back to normal. Thanks

I am noticing this with my game as well. Would prefer not to have to uninstall and lose my saved games if I didn’t have to.

And after it was supposedly fixed…its back again

Still broken. All text appears jumbled just like before. Multiple restarts have done nothing

This is a steam bug, if you select the game under steam and select the ‘verify integrity’ option for that games options, it will fix it. We have no way to fix it, as its steam corrupting some files…
That should fix it though

Thanks. Fixed

Im having the same issue here on Mac. I have put many hours into the game, and only now has this happened.
My game is fully up to date, yet I still have this problem.

validating your game cache will fix the issue… we have a new version in the test branch on steam that will detect the corrupted (0-byte) font files and force Steam to re-validate the game and fix the files.