Annoying stutter


#1

I just pre-orderede GTB today, and immediately went into the beta of what looks like could become my fave TD ever.

But, I am experiencing some annoying stutters when playing, both in visuals and audio, and i’ve yet to determine some sort of pattern to it, it just appears to happen at random, and not just when a lot is going on.

I’ve played the first two missions, and it didn’t happen at all in the first one (defend), but does in the second (attack)

Also, I tried restarting a couple of times, stutter is the same.

Specs: Intel I7-930, nVidia 580 in dualscreen setup, 12 gigs ram, Windows 7 64 bit.


#2

Played another round, it seems to be happening when something blows up, but not every unit, and not even the same type every time.

I should probably mention that my soundcard is an Asus Xonar DX.


#3

I recorded a FRAPS video of the problem, which i’ve uploaded to youtube

youtube.com/watch?v=NLE5rAiO … e=youtu.be

FRAPS does not record the FPS counter, but FPS drops from a solid 60 to somewhere in the neighbourhood of 10 when it stutters.


#4

Interesting.
This may seem surreal, but have you ever defragmented your hard drive? or are you low on disk space? I am theroizing that it is disk access that may be the cause.
Also, it might be worth going into options and basically turning of ALL the effects you can, then seeing if it can be reproduced. I’d definitely like to fix this for you if possible, the game should run at 50-60FPS constantly for almost any PC.


#5

Disabling everything changed nothing in regards to the stutter, drive has 200GB free, and no files in the GTB folder is fragmented.

It would seem that either disk access, or something related to queuing up sounds/playing them is the cause.

I’ll try and reinstall the game on my SSD, just to check.


#6

Well, I moved the folder to my SSD, problem not present, then I moved it to another standard HD, problem not present, then I moved it back to its original installation folder, and, problem not present.

But, as I said, the first mission I played, in the original install folder, the problem wasn’t present either.

I’ll play a few more missions, and see if it returns.


#7

It returned, but moving the installation away from the original folder to another disc, and then back again, fixes it … I have NO idea as to why that could be, other than some internal Windows voodoo.

I am not running any A/V or malware realtime scanning software, so it can’t be that.


#8

Onboard or discrete audio? OS? Does your CPU run particularly hot (might be throttling, different games react differently to sudden changes in clock speed)? Done a disk cleanup/CCleaner run recently (temp files SHOULDN’T affect performance once you’re in an app but you never know)? Any errors showing up in your event log for missing files or application errors? How does your system deal with more demanding apps?

Mostly brainstorming here, looks like an interesting little challenge :stuck_out_tongue:


#9

Hmmm, it’s not somehow related to SSD housekeeping of some sorts, regardless of where the game is installed maybe? I dont have any experience with SSDs, I just wonder if that stuttering is maybe happening all the time, and it’s only actually showing up in a CPU-intensive app like GTB. does video playback work fine?


#10

As written, its an Asus Xonar DX, so no onboard (the one there is is disabled in BIOS)

I’ve not experienced this problem with any other game, except maybe for Source based games before I changed some ingame latency settings (before I got the soundcard I have now), but that is an old well-known problem in the source engine.

CPU and GPU are within normal temperature range, no hotter or colder than when running other games.

The strange thing is, quitting the game, moving it to another disk and back, fixes it for a while … I haven’t tried keeping it on another disk for extended play, though, it might just be that one disk that is broken (but as said, I haven’t had a similar problem in any other game)


#11

If you’re still running the drivers that came with the Xonar, you could try updating them - Asus did release a new set about half a year ago and it did seem to improve things a bit (great driver support guys…); Additionally, disabling GX has been shown to improve things.

Aside from that, I pretty much got nothing at the moment. Cliffski’s guess sounds reasonable - this may be a pain in the rear but if you have some time to spare, maybe try setting up a VM purely on one of the platter drives and see how it works.

Another thought is that it could be an issue with dual screens - I’m guessing you run an extended desktop, does the game stretch across both screens or just across the primary? Try running the game in windowed mode and see how it works out.