Another Save Game bug?


#1

After installing the most recent patch, when trying to load a saved game, I get this error:

Tag story expected found royalties: C:\DATA\PROGRAMMING\MIL0\SIM_LoadGame.cpp 213

Starting a new game and saving it and reloading it doesn’t have any problems though.


#2

I had the same problem.
Cliff told me how to fix it pretty quickly.
See here. http://positech.co.uk/newforum/viewtopic.php?p=1581#1581


#3

I’ve tried this and when I search for in the find box, it can’t find it.


#4

thats weird, email me the save game, Ill fix it.


#5

I emailed you the save game so you can fix it.


#6

I have a similar problem, but I get the following error message.

Could not find job:C:\DATA\PROGRAMMING\MILO\SIM_JobBase.cpp 396

I tried inserting the extra XML after , but that didn’t solve the problem.

I have another save game that is close to the one that causes the problem, but when I try to load that one, I’m unemployed. The difference between the two is that in the first one (the one that produces an error message) I’m a partner at a law firm and in the second one, I just accepted a job as an actor. As far as I can tell from the content of the save games (and as far as I can remember from the last time I played) they are the same otherwise.


#7

Ok people, I HAVE FOUND THIS BUG! I’m so pleased, it was a bit obscure, but I’ve got it this time. It’ll be fixed in 1.11. phew


#8

Congratulations! You rock, my man. 8)