Beta 1.15 Crash/Error [run the game as Admin]


#1

System: Macbook Mid 2012
Parallels 10
Windows 7 set with 4 CPUs 8GB memory 2GB Video Memory

After hitting “Fight” it starts the little load circles, then freezes. Hitting ctrl+enter lets me see the error on the desktop:

Failed to write ship design: [data/sampleships/sample fighter.txt]:…\src\SIM_ShipDesign.cpp 358

Reloaded and tried again, this time no “Failed to write…” popup, but it still crashed. Noted it did get a bit farther in the blue circle (57% this time).

Will keep trying to see if it will ever get to 100%

(one of the crash detail windows had this:
Problem signature:
Problem Event Name: APPCRASH
Application Name: GSB2.exe
Application Version: 0.0.0.0
Application Timestamp: 54d38fbb
Fault Module Name: GSB2.exe
Fault Module Version: 0.0.0.0
Fault Module Timestamp: 54d38fbb
Exception Code: 80000003
Exception Offset: 00008be2
OS Version: 6.1.7601.2.1.0.256.1
Locale ID: 1033
Additional Information 1: 0a9e
Additional Information 2: 0a9e372d3b4ad19135b953a78882e789
Additional Information 3: 0a9e
Additional Information 4: 0a9e372d3b4ad19135b953a78882e789

Read our privacy statement online:
go.microsoft.com/fwlink/?linkid= … cid=0x0409

If the online privacy statement is not available, please read our privacy statement offline:
C:\Windows\system32\en-US\erofflps.txt


#2

Judging by the huge number of identical posts to this, it seems everyone has this issue. Running the game as an administrator works on Windows, but I’m not sure about Mac. It will eventually get to 100% if you keep just reloading, fortunately.


#3

That’s what I get for not thoroughly checking for past posts…

I do think I am admin on my Windows setup… It did get around to running, so I can not test if that would fix it anymore :-/


#4

The specifics of the bug cause it to crash every time the game loads a preset ship for the first time. So running the game as an admin will save you from having to go through the same process every time you play a new battle.