Beta 1.15 Failed to initialise 3D engine:..\src\Game.cpp 435

Bought the game today, and after installing the game and starting it, the menu music plays on a black screen, and in a new window the error message
Failed to initialise 3D engine:…\src\Game.cpp 435
appears. Then, it says “GSB2 is not responding”. I have found no other errors to do with this, so I don’t know what to do. I have tried reinstalling, updating my drivers and restarting, but to no avail.

HP Envy Touchsmart 15-j122ea running Windows 8.1
Intel® Core™ i5-4200M processor
Memory: 4 GB
Graphics: NVIDIA® GeForce® GT 740M

Please help!

EDIT: Found a fix, you just need to edit properties for all permissions and to run in compatibility for Windows 7.

Hi, glad its running, but compatibility mode certainly should not be required. Are you running beta video card drivers? (or old ones?)

I ran into the same issue (with 1.15) and Win7 compatibility mode fixed it.

My video card drivers are only slightly out of date (running Nvidia Geforce 347.25, it’s prompting me to update to 347.52). Video card is a GeForce GTX 760, OS is Win 8.1.

I couldn’t get the auto-update to work, even after entering the online challenge code, but I re-installed with the new package and this issue seems gone with 1.16 (although it could just be a first-time-only sort of bug).