Beta 1.16: Auto-Update to Beta 1.17 not working?


#1

When I started the client, there was an update… - I went away and when I came back I was back to desktop. After starting the client anew it started normally (without updating), but the main screen still shows “Beta 1.16”. Did I get the update or not? (Since I went away without watching the progress and not seeing any “install” or “fail” window… - I just don’t know.

Edits: changed the subject to better comply with rules / make it clearer on just reading the subject.
And since I was requested to split up bug-reporting and general feedback, which doesn’t seem to belong to the support forum, I cut&paste the rest of this post into a new post for the normal forum.


#2

You do realise that nobody is saying this is a finished product, right? The whole point of opening it to the public in its current state is precisely so that all these issues can be found and fixed. If you just want to play the game, I’d recommend waiting until release day. Also, if the beta hasn’t updated properly (and it sounds like it hasn’t), try reusing your download link from BMT micro.


#3

Same thing happened to me - pretty sure you did NOT get the update (I didn’t).

However, I was able to find the downloaded patched .exe file in the “patches” folder (I’m unsure of the exact path and I’m not near my home computer right now) and I ran that manually which successfully patched me to 1.17


#4

Thanks: I redownloaded using the old / still valid BMT micro link.
Now main screen shows Beta 1.17.

The other in-game-issues are still the same. After all you are right: it is a beta and will check back for updates or wait for release.