Beta 1.17 Installer - Corrupted Files


#1

I bought the game today and downloaded the installer via the provided link. I tagged it 1.17 because that’s the version I see on the first page of the installer. I receive the following error when I attempt installation:

“An error occurred while trying to copy a file:
The source file is corrupted.”

I see this for data\bitmaps\bitmaps.pak. If I ignore the error I then see it for:
data\composites\comp_0.ini, up to comp_15 and higher
default ship design txt files, etc.

I downloaded the installer multiple times for different mirrors, made sure it wasn’t in read-only mode, unblocked Windows non-digitally signed warnings, ran it in compatibility mode, as administrator, ran it from a different hard drive, installed it to a different location, ran it from another computer, etc and nothing worked.

Edit: Using Windows 7 64-bit.

I tried searching other threads and didn’t come up with much, but I did disable my AV (MSE) and got the same result. I ran an updated malware search and a full AV search and also came up with nothing.


#2

Hi, I just checked todays version, and the new installer, and it definitely doesn’t mention 1.17 anywhere. This is the link provided by BMTMicro yes? to GSB2Beta_Installer.exe, its size is 265 MB?
Cheers


#3

I got it from BMT Micro, yes. The file name is correct. I used the link provided in the email as well as the manual download from the site using the provided product ID and password fields. Windows reports it as 259 MB or 271,839,904 bytes
Edit: screencap of my installer page

I also tried downloading it in Firefox instead of Chrome and got the same results.


#4

Well, it works now. I downloaded the installer again and the only thing that I can tell you is different is that Windows has the
“While files from the internet can be useful, this file type can potentially harm your computer…” warning (yellow shield icon) instead of the red shield icon, which stated,
“This file does not have a valid digital signature that verifies its publisher…”