[Bug 1.761] Map Editor Shenanigans

So, I tried something insane, a max sized map, 200x200. Here’s what trouble I ran into…

  • If you drag a box from bottom right upward, you create a “negative zone” area that has no tiles, but still shows up in the game as a building to lease.
  • The first building you draw should be automatically unlocked. It’s possible to start the game with all locked buildings and no way to progress, not knowing there’s an option buried in the sidebar that lets you set the building unlocked or locked.
  • I accidentally set the rent to 200, not realizing it’s per tile. The game doesn’t even try to collect that rent. Which is $8 million an hour in case you’re curious.
  • Right-click to delete? Terrible idea. Needs confirmation or a separate tool. I accidentally deleted the giant zone way too many times after getting the import/export slots and offices 90 percent done.
1 Like

yeah it needs a lot of work.
I’ve tried using it and if I spent the time on it I know I could get it to work eventually but I just can’t be bothered due to some of the issues you had and probablly some other ease of use things that I don’t recall

Using a custom map of 100 x 100 im also seeing long delays where the program will freeze and if you wait it does clear but now and then it will lock up completely. i checked the memory and cpu usage and they were all fine but for some odd reason the power usage was maxed out? This is shown in the task manager of windows 10