[BUG] Can't use Cruiser Plasma Launchers in a design


#1

Hi, I haven’t played much yet, but did notice one odd thing.

Whenever I try to put Cruiser Plasma Launchers onto one of my ships, they are converted into Light Plasma Launchers when I save the design. I’ve tried this with a few different hulls, placement, &c.


#2

I’ll second this bug, thought haven’t tested since 1.01 (since a cruiser full of light plasma launchers is pretty nice as well :slight_smile: )


#3

I’m fairly sure this was fixed in one version or another… at least, when I patched, it overwrote my data files where I had fixed it myself, and it stayed fixed.


#4

Cliffski hasn’t mentioned it in the patch-notes so I assume he hasn’t fixed it yet. Anyway, see this thread for a temporary fix.


#5

Bad penny light plasma is still present in 1.03.

This happened to me twice in a row, it might be reproducible.

Accept a challenge.
Load a formation.
Go to ship design from deployment screen.
Load a cruiser design with light plasma hardpoints.
Try to get cruiser plasma module to stay put in a hardpoint. Save and reload to see the light plasma pop back in the hardpoint.
Give up, click to return to deployment screen.
Application crash.

My first app crash since beta 1.0! Excepting the date .ini bug thingie.


#6

The crash is reproducible, mentioned and acknowledged elsewhere, and unrelated to the plasma thing.

I must apologise, as I thought Cliffski’s patches were less intelligent than they are - they don’t modify anything they don’t need to, so, they left my fixed datafiles alone.

Here’s how to fix your plasma bug, and a few others of the same type. Hope that helps.


#7

Thanks guys.


#8

This is also happening to me with my Frigate Missile Launchers converting to Anti-Fighter Missile Launchers during deployment.


#9

That’s utterly fascinating, as I’m experiencing precisely the opposite effect of said bug. It’s annoying as all HELL, but when compared to your own experience it’s quite intriguing. This bug has only showed up for me since I patched-up to 1.04 a few hours ago. Cliffski, your thoughts?


#10

Maybe a different sorting scheme on your hard drive - they both have the same internal name, so the game just loads whichever it ‘sees’ first. Change one, and they’ll work.


#11

I also experience this problem, but since I use Heavy Plasma anyway it’s not a real problem for me, but when I do try and use Cruiser Plasma it turns into light plasma.