[Bug] Challenges - Tribes


#1

I created a Tribes fleet and posted a challenge using the Battle of NGC map.

It said it accepted it but I can’t see it. I see my older challenges but not the one I just posted.

I tried it again and this time addressed it to myself rather than All. Still didn’t appear on the challenges list. Quit the game, logged back in, refreshed again, still not there.

Also, I can’t fight the battle from “Cliffski” called “Give up your hopeless attempts…” Says I’m missing something. Maybe you had a mod, I dunno, just thought I’d mention it. The one from Erik works fine.

Lastly, when I posted the challenge there were 2 check boxes – one blank and one for Tribes. I don’t have any mods.


#2

I have the exact same experience -
If I post a challenge on NGC to myself, I can’t even see it in the list of challenges I’ve posted…
I can’t fight cliffski’s challenge
The tickboxes on the challenge screen are a bit misaligned (too high), one blank, one for Tribes.

I can fight challenges I post using Tribes content on the original scenarios.


#3

This is definitely the problem. I shall check the code, but can you check there are only two files in \Program Files\Gratuitous Space Battles\data\packages

They should be

gsb_tribe.pkg
gsb_base.pkg

And you should be getting only one checkbox. I wonder if during the upgrade process an older version of gsb_base.pkg got left there. Of you open it in notepad, it should contain this:

[config] name = gsb_base uiname = "Core GSB Game"


#4

i have the same problem and – hmm? wait. you said that you need both gsb_base and gsb_tribe? damn. i only have gsb_tribe.


#5

I have both files.
The contents of gsb_base.pkg was just

gsb_base

I have corrected it manually, by putting in the info you quoted.

I can now play cliffskis challenge (and beat it by 98% with my own Tribe fleet :stuck_out_tongue: ), can see my own challenges on the new maps, and now only get one checkbox (for tribes) as expected when making challenges.
I become unable to play the challenges I’d posted up while experiencing the bug, but that’s expected, since it was expecting me to have some nameless mod installed :stuck_out_tongue:


#6

I had the same problem and fixed it the same way.


#7

It would be handy if anyone in this situation could delete any challenges they know are corrupt. It’s a bit of a swine for me to automatically find them.
Cheers :smiley: