[Bug] Crash when attempting a 2nd challenge


#1

This happened occasionally prior to 1.27, but it seems much more common post-1.27. When I win a challenge, I’ll typically rate it, go to stats, and from there go to the challenge list via the “main menu” button (misleadingly named). I’ll download a new challenge, set up a fleet (this happens both when loading a deployment, and when building on from scratch), and attempt to start the battle. The sound runs into a quick repeating loop for 2-3 seconds and the entire game crashes before even reaching the loading screen.

Note that I’m referring to the online challenges, not the single player default scenarios. I haven’t actually tried playing those since early in the beta, so I have no idea if they cause the same problem.

I’m running the non-Steam version of the game under Windows XP.


#2

Oh finally, someone else.

I’ve been trying to find a pattern for that thing for a while now. It’s an immediate CTD upon hitting the ‘fight’ button. I don’t even have to select a new challenge, usually I hit that crash when I’ve been experimenting on the same challenge repeatedly. Haven’t played much 1.27 yet but it certainly was prominent in 1.26.

The only thing I can say for certain about it is that it never happens on the first deployment after loading the game.

WinXP, steam version. No tribe.


#3

Actually, post 1.27, this is now happening on other screen transitions as well, including ship design and simply going to the challenge list. But always after completing at least one challenge play.

Oh, and I do have Tribes.


#4

Interesting. I haven’t read about this before. I shall attempt to replicate it (and then obviously fix it :D)
Cheers


#5

got similar crashes. After wining a challenge, rate it, going to stats and then to deployment screen. Most of the time I get a crash there.


#6

I cannot reproduce this at all, I have tried lots of times. Does anyone who experiences this have anything in \program files\gratuitous space battles\debugdata\errors.txt?


#7

I do, but since the date in the log doesn’t match today don’t think it’s related.

30/11/2009 - 23::12 - Assertion failure:filename:..\src\GUI_TitleBar.cpp,linenum:25,build:Full 1.26 1/12/2009 - 23::28 - Assertion failure:filename:..\src\GUI_TitleBar.cpp,linenum:25,build:Full 1.26


#8

I haven’t had a ‘fight’ button deployment crash since the 1.27 patch. I’ve had a few crashes going into the ship editor from the deploy screen, though.

Nothing in the error log seems to correspond to today other than this:

8/12/2009 - 4::27 - Untranslated HRESULT 8/12/2009 - 4::27 - Error creating texture:[$s]

And there’s only one entry - I’ve had the crash multiple times today.


#9

Is there any chance you can narrow it down? There must be something you are both doing that I’m not when I try and replicate it.
I’m testing it with a very specific challenge which i play at 4x speed and win very quickly.
Do you have to win for to go wrong?
Do you have to rate the challenge for it to go wrong?
Are you running untouched copies or has any modding taken place?
Fullscreen or windowed or does it not make a difference?
Are all the options set to their defaults?

Thanks, it’s a nightmare to fix a bug you can never see happen :frowning:


#10

I know the feeling. :frowning:

I run windowed (but it has happened fullscreen), 1200x800, max default options except pitch shift and music volume to zero. I rarely rate challenges, and if I do it’s not a second time so there’s not much correlation there. No mods.

I still haven’t managed a deployment crash since 1.27, but I just had a few editor crashes:

Tried a cruiser out on Caspian IV, against dogthinker’s “aggressive rebel” fleet. Loss. Came back to deployment (through the statics window), immediately right click and hit ‘edit’ on one of the designs I had deployed. Icon was orange due to it being too expensive. Crash.

Did it all again (deploy, loss, deploy, editor), same icon, no crash. As an aside, I notice that the initial item selected in the editor window is pretty random (fighter armor for a cruiser, in this case), what’s with that?

After a few dozen times doing the same, each crash (so far) has been from selecting edit for orange iconed units that I actually have deployed, after at least one or two deployments. I even managed one crash in the attempt from successful editor->deployment->back to editor, but I can’t replicate that. I’m speeding through the battles on 4x speed, all are losses, no rating, always going back to deployment through the statistics window. I click fast, so often I bypass the ship tooltip that pops up, if that’s any relevance.


#11

I want to know too, because I cannot replicate it any longer. When I reported It would happen every time I would try with the vague instructions I provided, but doing the same I was doing (same challenge, same deployment), I cannot get it happen again. Tried already 20 times. =(

Although pointless I will answer the questions (as I can’t reproduce now)

Although pointless (as I can’t reproduce now) I will answer the questions.

The challange was one from someone called Borktastic, Taut: The fleet easily beats the expert settings, Map: Chaos Nebula, date: 11/23/09.
I tried many variations based on fenrir cruisers with only MW missiles and laser fighters.

I didn’t lose so I don’t know.

All the times I rated it, the game crashed

nothing modified

When I got the crashes was always fullscreen (1280x1024)

All options enabled, all sounds lowered and music disabled.
other info: windows xp sp3, launched from steam, avast antivirus (free edition), amd64 x2 3800+


#12

Apologies for bumping an old thread - but I’m still getting these (1.31).

It originally occurred to me that deployment size might have something to do with it. I often use large numbers of cheap ships, to the point where ships get named “Ship_2453” rather than one of the stock names.

I had a fleet of 120 frigates on Caspian IV that was crashing very consistently.

After the first match, I could select all, change a range setting, deselect, launch, crash. Immediately leaping into the same challenge after each one.

After a while, I decide to save the deployment (in the ‘deployed’ default slot) and try it in the single player. Since I’ve done that - no crashes, even after several reboots of the game.

I’m at a loss there. I’ve noticed that after a crash on a challenge, my fleet is still there by default, but it’s not one I’ve explicitly saved. Could that behavior have something to do with it?


#13

Any chance it could actually be memory related? If are able to open up task manager and have it running ( have dual monitors, so its easy), it might be that the game just physically runs out of RAM, or it gets high enough that weird things go wrong?


#14

Okay, I may have lucked out and gotten a cycle. What kind of info do you want?

342,212k mem usage at time of crash, after a match with around 140 frigates.
314,776k the second crash.

It doesn’t seem like that much - I usually push firefox well beyond that and this computer isn’t exactly a slouch.

Unfortunately I seem to have somehow broken the cycle so I stopped getting crashes. It seems to have leveled off around 480,000k-570,000k on that scenario, repeated runs, without closing the game.


#15

Thats definitely not too much RAM, so maybe that isn’t it :frowning:


#16

I was fine for the first 2 weeks of having this game, but I’m getting it too now.

It doesn’t seem to be all the time…I’ve noticed it happens with certain deployments and certain challenges.

The only thing that is new now for me (besides the recent patch) was that I looked at certain files with a text editor. I didn’t save any changes, but could GSB be having read or write problems to those files as a result? What is the exe trying to do in those moments?

I save deployments and get a crash, go back into GSB and the changes saved. I beat a challenge, tweak my deployment a bit, and go to try it again and get a crash when I click the fight button. I go back in and it allows me to fight this time. Wash, rinse, repeat.

I am using XP64 as my OS with a 8800GT and 4GB of memory.

Cliff, let me know if you want to check out my files to help you narrow this down.


#17

does the game write any errors to
\program files\gratuitous space battles\debugdata\errors.txt that seem to coincide with the crash?


#18

No, my errors.txt is completely blank.