[Bug]Failed to save high scores:...\src\SIM_HighScores.cpp


#1

I don’t know what’s causing it but every time I win the first mission, just as the last ship is destroyed the game crashes and comes up with the error box above. The only things I’ve done since Installing the beta was to turn off camera blur and to design a couple of ships.

Failed to save high scores:…\src\SIM_HighScores.cpp 370


#2

I’m getting the same issue.
Bought the game on Steam - currently running v 1.23.
I’ve tried taking the game off my machine completely and re-downloading, but without any luck.
Any suggestions?


#3

This sounds liek the game isn’tbeing allowed to write a file to the hard drive. Is this under Windows 7? or maybe you are running windows as a user without administrator rights? (they shouldnt be needed anyway, but still worth checking).


#4

Nothing that flashy & new, I’m afraid.
Windows XP SP3 logged in as Administrator.
My machine is slightly lower spec (by current standards) - P4 Dual Core 3Ghz, 2Gb of RAM & an Nvidia Geforce 7300 video card.
But it runs perfectly, right up to the point when the last opponent explodes.

I’ve tried granting specific rights to the My Docs\My Games\GSB folder to all users, just in case it wasn’t granting the rights properly.
Made no odds, unfortunately.


#5

Very weird. I shall investigate further. The spec of your PC shouldn’t matter at all regarding this. It’s very unlikely, but I presume you haven’t run out of disk space? The game should trivially be able to write there. No anti-virus/security stuff maybe intefering with disk writes?


#6

I am running AVG 9, but I doubt that will be getting in the way.
I’ve just turned off scanning on the My Docs\My Games\GSB folder…no joy.
Once I’m off-line I’ll turn off AVG totally and give it another try, then I’ll let you know.

Disk space isn’t a worry - 101Gb free at the moment.


#7

I ran into this same issue, after running the game successfully 3-4 times.
I had this problem 3 times.

At this point, possibly unrelated(?), the game won’t launch.

I am on Win 7 RC7100, x86
After buying the game it ran flawlessly, no need to run as admin, but I ran on an admin account after issues to test (both issues).
I did try going to the directory directly to launch as admin, with no luck.
Uninstalled and installed, same issue. Did it again the next day, same problem that will not launch. I get this error:

Purchased on Steam, running in their client. Other games are running fine.
I have not installed the update since the game ran fine before. Whatever version Steam has is what I’m running this on. Steam is up to date, drivers up to date, rebooted, open on firewall in case of validation issues, nothing blocking the game. Run as admin with no luck.

I’ll post this and another issue there when they activate my forum account.
Maybe a Steam problem on that second issue? Did the original poster purchase on steam or other means?

Edit: When launching the game, steam pops up my product key. I have not seen a place to input that, could that be the issue?


#8

Follow up:

Looking for info on the Steam launch issue, I ran across a thread in the FAQ about it (on other machine or I’d post link).
The pop up I got is apparently associated with some file being reset to “read only” which makes sense for our other issue here with the game save.
The “fix” for that involved deleting most files so Steam would rebuild upon log on. I did this and still get the error.
I went to properties for all of steam and then again for GSB and made sure the directories are NOT marked read only (toggled r/o and then not r/o per their instructions).
No change so far.


#9

Aha…

Do any (or all) of you people have your /MyDocuments folder relocated to a different position than normal? Like on a different disk?
the game SHOULD understand that no problem, but I have heard that it may not, due to some arcane windows code nonsense.


#10

In Win7, it’s a little different when looking since it adds this (annoying) library function, but here’s where I see GSB. Win7 maintains a games directory on it’s own automatically. Some games have directories under Documents, some are put in the My Games subdirectory.

C:\Users\Bill\Documents\My Games\GratuitousSpaceBattles

Tried restoring game from a restore point with no luck. I played with compatibility mode before uninstalling (after these issues), but only at the main game installation point, not in the Documents area above.

I uninstalled Steam and reinstalled to see if it does it again. Running fine now, I’ll mess with it and see if I can get it to do it again.
*The My Games file was not deleted when I uninstalled. When I reinstalled I still had my game save and old screenshots.
I set all directories back to win7, uninstalled. Reinstalled and Steam gave me a pop up not to have any steam files in compat mode?

When I reinstalled, I got a pop up about a patch which I didn’t get before, but maybe it was due to going to the online section which I didn’t do before(?).
Looks like it upgraded to 1.23, I did point it to the game directory in the steamapp directory to do the patch.


#11

Another patch after launching through Steam, but from the game connecting I assume. Said 1.25. On the menu screen I see 1.23 in the upper right corner. Should that be 1.25 if the patch took?


#12

Yes it should, which strongly suggests that the patch has been installed into the wrong place. you can reapply the patch to fox this, its in \mygames\gratuitous space battles\patches


#13

Got beta patch 1.26 today, had the same problem as when I went back to install manually.

Applying the patch from the location you mentioned, ran as admin and it installs.
Launch game and I get this:

However, fmodex is in the root directory of the game already:
C:\Program Files\Steam\steamapps\common\gratuitous space battles

Should I be running these patches sequentially to take care of the recognition problem, or is each patch independent of the others?
Does Fmodex need to be copied to the other directory in My Games?
C:\Users\Bill\Documents\My Games\GratuitousSpaceBattles

The game is still running, but patches aren’t taking.
(Maybe this should be a different topic)


#14

I type this in almost every thread now :smiley:
You need to install the patch to tjhe place where the game is installed.
that is NOT in MyDocuments
Its in some offshoot of program files, depending on whatever path the people you bought it from decided to add to it. That might be steamapps, or positech games, or whatever.
But its the path to the folder that has GSB.exe , fmodex.dll and so on…in it.
If you don’t install the patch there, it won’t work