[BUG]Lots


#1

I compacted these from a couple other threads. I didn’t realize that bugs were suppose to be posted here.

  1. Under a challenge I put up titled: Imperial scout fleet detected… Moving to intercept
    When the imperial ships are attacked with a heavy plasma cannon they vanish. Not destroyed and not cloaked, they just vanish. When I created the challenge there was no cloaking devices installed on the ships. Other weapons seem to hit, but I have not gone through the other plasma cannons and ALL the other weapons. Repeatable EVERY single time.
    Version B1.02

  2. “SHIFT” keys 1 through 0 are not working in challenge mode, i.e. !@#$%^&*(). Always.
    Version B1.02

  3. Before the Registration Code is entered in the online menu:
    If you click on the registration box, not the text box, the game will crash. If you click on the text box within the “Registratiopn Code” box first there is no problem. Clicking anywhere else on the screen before or after does not cause a problem. Repeatable EVERY single time.
    Version B1.01 (Haven’t tried since updating)

4.Giving the escort or formation order:
If ships are placed to close together you can’t always select them as a target. You hear the sound, but no text comes up in the box and you can not click OK. The bug doesn’t happen all of the time.
Version B1.02

Game name: Ruski


#2

For bug number 1. “Multiple Missie Launchers” also make the vanishing happen. Every time.


#3

Playing Another users challenge: Vanashing ships but not in a specific way, followed by a game crash and this error:

Intersect code went wrong:…\src\SIM_LightningGunModule.cpp 139

Challenge: An alliance shock formation has entered out sector. Take command of our fleet and wipe them out.
User: Strumpie


#4

Hi, are you playing an older version (1.00)? Check the top right of the main menu. That intersect bug should definitely be gone by now.


#5

Just tripled checked. I am running version B1.02


#6

For vanishing ships: For the last 12hrs of playing everything has been playing very well without problems. All of the sudden in most challenges ships will vanish, some cases are faster than others.

I’ve been trying to think over what has changed, but I can’t find a specific item.

What I have tried:
Removed newly created ship confings: No change.
Removed newly created deployments: No change.
Removed all downloaded challenges: No change.

I would venture a guess that is has to do with a file that is changed after use. Just a guess.


#7

Vanishing should be fixed in 1.03b.