[BUG] Nomads: Thrusters not rendered correctly


#1

Hellos.

I just bought the Nomads via Impulse and had it installed into my GSB folder. However, in the game, all Nomad thrusters, i.e. the usually glowing thruster exhaust flame thingie, are shown as large glowing white rectangles. While this is most gratuitous, it is not the gratuity I’m looking for. Whatever will I do?

Best regards,
Z.

SOLVED: http://positech.co.uk/forums/phpBB3/viewtopic.php?f=21&t=5419#p36837


#2

Appears it must be my unlucky day. It so happened that I thought I might as well go for the Tribe while waiting for an answer to my Nomad woes to come up, but as it turns out, with the Tribe the ships don’t have any thruster exhaust graphics at all…


#3

Z., I’m sure that this isn’t the most constructive item to add, but I was greatly surprised when I read your report. I’ve never seen that sort of bug before, and would also be most curious to discover how the Nomad engine glows became corrupted. It’s as if the game forgot where the engine glows were saved and when the time came to display them, it panicked; hence the white squares.

The fact that the Tribe ships appear in your copy of GSB with zero engine glows deepens the mystery. Do you also have the white squares behind Tribe ships on the map? Or are you literally seeing nothing but the map background at those locations?

I’m sure that Cliffski is going to want to know what version you’re playing…are you using the latest GSB, which is 1.47?


#4

I have the same trouble with one of the thrusters with my gsb also, I noticed it while I was working to get the Caldari dragonfly’s thrusters looking right. As i go thought the selection of drive glows one appairs as as white box. I’ll look into it more later, but i have many many other things to do mostly college work.

toodles
Lonestar


#5

That’s a texture not found bug. I suspect I might know what this is. Is this happening only to people who have the nomads expansion but NOT all of the other expansions? If so, it’s me forgetting something :frowning:


#6

I have no DLC content at all, so I think its just an error in the file. I’ll have to take a looksee and see whats going on for me.


#7

Mysterious indeed. I have tried out both the Tribe and Nomads on the same map, and both do in fact behave differently: The Nomad ships are propulsed by the white blocks, which themselves have the usual trailing “particle-specks” coming out of them, respectively. The Tribe don’t show the white blocks, but simply have no exhaust graphics at all, not even the particle-specks. So there’s always just the map background visible behind the thrusters with the Tribe.

I am indeed using 1.47. I’ve purchased the base pack from the Positech shop, while the expansions are courtesy of Stardock, but I assume that shouldn’t make a difference.

As for me, I do only own the Tribe and the Nomads, as for now.

How come there’s no white block where the Tribe exhaust flame should be? As for the scattering trail of particles which follow the exhaust flame, are those textures too, or rendered on the fly?

Curious and curiouser… %-\


#8

So, I just thought ‘What the heck’ and bought the remaining two expansions, given they’re on sale and all. Here’s what happened: The thrusters of Swarm and Order ships all seem to work fine. And what’s more: The Nomad thrusters, which used to be white chunks of empty texture, now work as well.

However: The Tribe still seem to be driving a green agenda, propulsing themselves through space without any thruster exhausts at all… Any ideas?


#9

The tribe have their own special engine glow texture, and its in \gratuitous space battles\tribe\data\bitmaps\tribe_engineglow.dds
Does that file not exist somehow on your system?
Do you have a high or low spec PC and Video card? I’m wondering if it’s simple running out of video memory for the texture but that is very very unlikely.


#10

Mh, the file is there all-right and contains a yellow to red gradient.

I’m running a Core2 w/ 4GB of RAM and a Geforce 9600M GS w/ 512MB.

shrugs


#11

Very strange indeed. Latest video card drivers installed?


#12

I just updated to the very latest nVidia drivers, but to no avail. I also reinstalled the whole shebang, GSB+DLC, but the Tribe still has no thrusters… :frowning:


#13

I have the solution: go into
(your game directory)\tribe\data\hulls\tribe\enter any non-fighter .txt file. Check the [engineglows] line.
If you have something like this: 0 = 171.50,250.50,26.56,28.75,TRIBE , change it to:
0 = 171.50,250.50,26.56,28.75,tribe_engineglow.dds,engine_debris_order,0,1.00 (and change it for every engineglow line in every non-fighter .txt file)

This is 100% checked, because I had the same problem, and figured it out a moment ago :slight_smile:

EDIT: If you don’t have Order expansion, change the engine_debris_order to alliance_engine_debris, or just engine_debris (it’s just for those “dots” going out from the engines)


#14

You, sir, are win. :slight_smile:

I wonder what went awry there… Did it just affect people who bought via Impulse?


#15

Thanks to Pivmaster for that example of pure elemental crystalline awesome, 100.0000000000% purity. :smiley:

FWIW, I’ve lurked the Support forum fairly regularly over the long term and I don’t recall anyone else ever mentioning this particular flaw before - either the exact version of what happened to drzanzi, or any variation of it. I wonder if it is an Impulse-specific glitch. It’s incredibly odd.