[Bug?] Posting challenge with custom mod


#1

Since version 1.25 (I have now 1.27) there is support for separate mod folders. I am now working on my own mod and it works fine until now.
I was at a point where I wanted to post a challenge online for my own testing purposes. For the moment no other has this mod because it is still in development so I was posting the challenge only to me.

My question is the following: Where is this new checkbox that i can tick to tell that i am using my Mod ? “Everybody” talks about it but can’t see it. Or is it no more necessary to tick the checkbox?

I created the file \Gratuitous Space Battles\data\installs\Danou.txt with this content:

[config] path = modDanou
My mod files are in \Gratuitous Space Battles\modDanou\

Sorry for my English.

Edit: I am talking about the checkboxes that are shown in this post by cliffski:
http://positech.co.uk/forums/phpBB3/viewtopic.php?f=21&t=2966&start=90#p21340



#2

You are looking in the wrong place for the mod stuff. The installs tells the game where the mods files are, but to state that a mod is present you need a new file in \packages
take a look at the base file in there (or the tribe one, if installed) to see how it works.


#3

Thank you cliffski, now it works!

You were right, I had to put my own package file in /data/packages/