Bug report: I'm having problems! Help! [Solved]


#1

I was wondering if anybody could help me out with some problems I’m having with this game. I should preface this by saying I had the game running fine yesterday, I can’t think of any changes I’ve made since then to cause problems. So without futhur ado…

I’ve solved this problem - see end of post for details

Problem

In the main menu (the one that you’re presented with after executing the programme). I click on ‘options’ - everything is fine, I’m presented with the options menu. However when I return to the main menu I’m being asked to validate the game (again!). I click the ‘validate’ button, I’m taken to the update/validation screen. However I can return to the main menu without any problems without contacting the server to update/validate.

Edit: this happens when returning from the ‘Load’ screen too, but not from the ‘New Game’ screen

The second issue is the ‘new game’ button. It’ll take four or five clicks before I’ll be presented with the list of the scenarios. When I click it the menu will do the ‘fade-out fade-in’ thing, but it wont move on to the next screen. As far as I’m aware all the other buttons work okay, aside from the odd behavior with the ‘options’ button.

When (if) i’m presented with the scenario selection screen, I can choose any scenario without a problem. I’m taken to the screen with the various sliders and options (term length, max terms in office etc). However when I click the start game bottom the menu fades-in/out, but it wont start the game.

It’s worth noting that I can get the buttons to respond correctly if I run the game in a windowed mode. That sucks though, because I’m running on 1900*1280 (or something) resolution, resulting in the game window being tiny!

Also, when I click on the advance turn button I get the same fade-in/out thing, but it doesn’t advance a turn. The same happens if I use the right click menu to try and advance a turn. However I can advance a turn by using the F6 key.

Edit: I’ve attached the debug reports now. I’ve put them in a .zip because I can’t attach plain text to this post

Steps I’ve taken to resolve the problem

a) Turn the PC off & on again!!!
b) Re-installed the software
c) Removed the software using the un-installer, removed the files in ‘My Documents’ and on my hard disk I use for games left over by the un-installer. Manually removed all the registry keys (the ones I could find anyway) in Current_user/software/positech. Followed all this by a re-install.
d) Disabled my anitvirus software (Kapersky)
e) Closed the Vista sidebar
f) Experimented with switching between windowed/full screen mode
g) Died a little inside!

All of the above didn’t have any effect. I’m not sure how to proceed next.

My system

Windows Vista 64bit
AMD Dual core CPU (5600 or something, one of the newer ones)
Asus Motherboard - nForce 560 chipset - Its the M2N-SLI socket AM2 one
Nvidia 8800GTX graphics board - overpriced, runs very hot, draws lots of power. Why oh why don’t we have graphics boards which are socketed, so we can upgrade them like CPUs… anway lol
4GB DDR2 800 RAM
2.6TB of HD storage, SATA2, not in RAID - This isn’t really relevant I’m just showing off

My speculation

I’m guessing the validation issue is some sort of registry problem? I don’t understand why it would run fine at first, but then fail to read the registry correctly after returning from the ‘options’ screen?

Is the ‘clicking-on-buttons-no-worky’ anything to do with running the game on a widescreen monitor with a funny aspect ratio?

Please help! I love this game. Now I’ve got to find some other way to procrastinate instead of doing my much needed revision!


Solution

After a little while messing about with this, I noticed that the game’s exectuable was set to run in compatability mode for MS Windows XP. I’ve no idea where/when I set that! Anyway, after removing the compatibility mode thing I I’ve run the game without any problems.

This doesn’t shed any light on the error mechanism that caused it to fail though. I’m assuming the windows XP compatability thing changes the way the program accesses the registry, or the way it interects with DirectX? Windows programing isn’t my strong point, so this is entirely speculation =)

Hope this may help some of you?

Nick


#2

Hi, sorry for the delay (been away!) and glad to hear you got it fixed. I guess that the compatibility mode does some silly registry-redirecting stuff. probably randomly and undocumented, knowing vista…