[Bug] Ship Design Crash and Missing Hulls


#1

Bought the game on steam and had no trouble with the original 1.23 or 24 build that was provided. After updating to 1.26 I ran into a problem after deleting some ship designs from the load menu from the ship design screen. When going to the deployment screen it still showed my ships and as I tried to delete them the game crashed. Full reinstall it happens again. I delete the tutorial ships from the ship design load menu and they still end up on the deployment menu and any attempt to edit a ship ends with a crash.


#2

I used Steam to delete the local content and I also deleted the folder in “My Games” which sadly lost me all my progress and unlocks. The game again worked fine until I deleted the tutorial ships from the deployment screen then hit the button to design a new ship. After that crash it crashes right away when trying to go into ship design from the main menu.

Faulting application gsb.exe, version 0.0.0.0, faulting module gsb.exe, version 0.0.0.0, fault address 0x000ce8e4.

I believe the conflict is where the game is creating deployment files for the tutorial ships even after the ships are deleted. I tried deleting the deployment files in the “My Games” folders and they reappear when you restart the game.


#3

Full reinstall using Steam after deleting the GSB folder from My Games as well. New install works fine so far as long as I do not delete the tutorial ships. So I am willing to bet that buy deleting the tutorial ships you create some sort of mismatch between the deployment files which are not only recreated every time the game starts but must be checked somehow whenever you attempt to get to the edit ship screen.


#4

The tutorial mission has a sample deployment and that deployment is automatically copied in there if it does not already Exist. that deployment uses the 3 initial tutorial ships, so I can see that causing problems. This shouldn’t matter at all unless you go that mission though. It might be that the game hates having no ships, in which case if you create some new designs before deleting the tutorial ones, it may be fine. I presume you are deleting them just to tidy up the list of ships in the ship selector?


#5

Yes, after the update to 1.26 via Steam I saw it recreated the tutorial ships so I deleted them from the load menu within the ship design section. That is what starts the mess.

Here is something. From the deployment screen I went to the design new ship to the ship and from the load menu I deleted one of my designs “hvy gunship”. When I returned to the deployment screen that ship was still an option to be added to my fleet! Something is not syncing when you delete ships between the load menu on the ship design screen and the deployment screen…


#6

After messing around a bit, I had this error too, but I found a solution.

If you delete any ship that has an associated deployment with it, it will crash. Since in the tutorial of the game, you save a deployment with the tutorial ships, when the game loads that deployment, and those ships arent around, it crashes. All you’d have to do is delete that tutorial deployment, and then the ships, and it should work ok.


#7

Yes but in the regular battles the deployments are autosaved. This is why I have been re-editing my ships because I am afraid to delete them.


#8

Well I just tried it. I loaded a battle with an auto saved deployment, went to create new ship, deleted a ship via the load menu, went back to the deployment and the ship I deleted was still there. Trying to edit it with the right click produced a crash with the hull not found. Luckily when I reloaded the game the error did not persist this time and the ship was no longer listed or used in the deployment screen.

This is certainly a bug and something needs to be revised to better sync the deletion of ships. Will the Positech see this here or should I submit this in another fashion so they are able to address the issue?