[BUG] Tracks bugs out

Game Version: 0.43.01
Mission: Beginner - Lost My Appetite
I was playing Big Pharma Mission “Lost My Appetite”, and I was trying to be smart with the production line, and then I tried to remove a track, it didn’t remove it.
And as show in the screenshot (screenshot_05_16_34 13-07-15.png) the tracks overlapped themselves, and when I tried to remove it, I can’t do anything anymore.
So when took a screenshot of this, Saved it where if froze at, and reloaded the save file, I saw what you see in the screenshot (screenshot_05_25_39 13-07-15.png)
So I had to go back to a later saved file of the mission, haven’t experienced it again.
I also included the save file with this bug intact, and the output log I found in the Game Folder.

Files Included:
1 Save file.
2 Screenshots.
1 Log file.

I couldn’t attach anything all because of this message “The file is too big, maximum allowed size is 1 MiB.
So you’ll have to download the files from here: mega.nz/#!zIohCDRI!AKGyGTSNvk3M … M_XlpvRW3U
Click Download to your Browser, When it’s done downloading it’ll ask where you want the file to be saved at.
Note there are typos in the text file, it’s supposed to be a copy of whats written before the Edited section.