[Bug V1.18 Beta] Alt-Tab Crashes


#1

Run the game.
Alt-Tab back to windows.
Alt-Tab back to the game.
Click on any main menu button besides ‘exit’.
The game will crash.

Run the game.
Enter the ship design or fleet deployment screens.
Alt-Tab back to windows.
Alt-Tab back to the game.
The game fails to restore the display. A black game window is displayed.


#2

Are you running the game fullscreen ? I have no problem alt tabing with it windowed.


#3

Yes, that’s in fullscreen mode, with an ATI graphics card.


#4

I have the same problems with alt-tabbing back to a plain black window. It doesn’t actually make it back to full screen - just a maximised window that is completely black but for the title bar and border. I had the same problem before 1.18 too, although alt-tabbing seems to fail all the time now, where before it seemed about 50% of the time.

I just tested alt-tabbing to the starting menu, and I get the same behavior described above.

Everything past the starting menu, that I’ve tried, seems to get the black window problem.

Running the game in windowed mode works a treat, so I play it like this. That’s a teeny tiny bit annoying though, as I have to run it in a window a bit smaller than the res I run normally, and that makes it just small enough that the ship stats get bumped to a seperate pane :slight_smile:

for what it’s worth, I’m running it on a Nvidia 8800 GT, but this strikes me as a windows gui problem.


#5

I’m getting this black screen too now. :frowning: And I want to play in full screen mode.

I did this: Launched the game, it downloaded the latest patch. Then after I had arrived to the main menu I hit alt+tab then alt+tab again, which actually made my firefox get selected. Then I alt tabbed again and scrolled to GSB. At this first time the game loaded just fine but when I hit battle the game just hard crashed.

See for yourself: i38.tinypic.com/14dzhx1.png

Well… Then I relaunched the game. I hit alt+tab and then alt+tab again and made sure the alt tabbing selected the GSB. Now I got the same error. A window of the game popped up (even I was running it in full screen mode) and everything what was inside the window was black. Also the window didn’t fill my screen correctly but it went a bit over it to the right and down.

Edit: Ok now this is really weird. I launched the game one more time (with fraps again as I had done every earlier time eversince I got GSB) and this time my FPS wasn’t capped to the 64 as usually but it was locked to the refresh rate instead. So now my SCREEN’S refresh rate changed to 75 (which fucks up my aligning of my view) and the game also used that refresh rate as it’s FPS. That was on 1280x1024 resolution.

Edit II: Ok… So I thought the game will fix itself I changed the resolution. The game again had 75 fps instead of capped 64. I changed the resolution from 1280x1024 to 1024x768 which is my normal desktop resolution and when I restarted the game, it now used the default refresh rate of my monitor… In other words it spit out 85 FPS now instead of that capped 64… So something is really seriously and badly wrong right now…

Though, now alt tabbing works just fine… The game only flashes the black screen in window for a short while and then loads up in full screen normally (with wrong FPS cap, which is still 85 on 1024x768 resolution.)

Meh… After alt tabbing back and forth and then clicking options button the game again hard crashed as shown in the picture. No more info about that (except the normal windows’ crash report stuff which most likely is no use for you.)


#6

Same issue here. Vista 64-bit, sp2. ATI graphics card


#7

To add, I play the game at 1280x1024 resolution.