[BUG][WIN] Menu tools disappearing when trying to click


#1

Hi Positech,

So, I am brand new to Big Pharma and I have loaded up the game for the first time, and to my dismay I’m not able to use the menus in the game. Every time I click on a menu item, it appears that the submenu is appearing only when I release the mouse button, and for a split second. Other interaction with the UI works fine, and it applies in all modes.

I have recorded a video of my experience here: https://youtu.be/I4AO4980TqM
Hopefully that helps show what I’m talking about.

My specs are as follows:
CPU: Intel i5-4460 3.20GHz
GFX: EVGA Geforce GTX 970
RAM: 16GB Corsair Vengeance
OS: Windows 7 Ultimate SP1

If there is anything else I can do to help you fix this bug so I can play your game, I am happy to help. Thank you in advance for your assistance.


#2

Hi Cybersteel8,

Sorry to hear you are having trouble playing the game.

I can’t be sure, but from watching the video it looks like the mouse might be registering right clicks instead of left clicks when you click the menus.

Here’s a few things to try:

  1. Can you first please just confirm that you are indeed pressing the left mouse button rather than the right button on the mouse?
  2. If that is the case, could you try switching buttons. IE Try pressing the right mouse button and see if that works. Whatever happens, please let me know what you experience as this will help me confirm/rule out what the issue is.
  3. There are hotkeys for the build menu which you can try using. Try pressing 1,2,3,4,5 etc. You can change these hotkeys in the options menu. This might help you select a machine to build but if the issue is to do with left/right clicks then you may still have problems placing machines because the right mouse button will actually deselect the tool by default.
  4. What mouse are you using? Could you try a different mouse and see if the problem persists? What mouse drivers do you have installed, perhaps this is a bug in the firmware and you can update them?

Let me know the results of these tests and we’ll go from there. :slight_smile:

Tim


#3

Hi Tim,

I managed to fix it. Your advice about the hotkeys lead me to the solution. For some reason, my key binding for “Open Basic Toolbar” which is normally 1, was actually bound to Mouse0 (left-click). I don’t know why that was bound as such, but your information lead me to find that. I changed it back to 1 as you suggested, and now clicking works properly! Because of this binding, every click I made would attempt to open (then immediately close?) the Basic toolbar, regardless of where I was clicking or what menu I was in.

Thank you for your help! I really appreciate your response. Now I can go ahead and play the game!

PS: I noticed that in your controls screen, there isn’t a button for “reset all bindings to default”. That would be a helpful button :slight_smile:


#4

Cool glad you’re back on track. Yes a default button would be a good idea. :slight_smile: