[BUG]WIN]v1.02.00 freezes on loading


#1

just downloaded v1.02.00 (PC-WIN) and it freezes when loading (about 50% mark - I think that is where it normally would punt if a MOD was involved).

I can’t recall if I had a MOD used last time I ran it, but will probably just clear everything out and try again.


#2

output_log.txt has:
IsolatedStorageException: Could not find file “C:\Program Files (x86)\Big Pharma\Big Pharma_Data\GameData\scenarios.data”.

I’m assuming that’s not good. No clue as to why I don’t have that file.


#3

putting a back up copy of scenarios.data in place fixed the problem, but I think that means I don’t have the new re-balance on several challenges.


#4

Dam! The autopatching stuff has really caused me no end of troubles. I tested the patch and it worked perfectly at my end, but I must say I’m a little worried that out of all the people it went wrong for it was one my my most regular forum contributors - you!

You could try reinstalling and repatching. It normally works better with a fresh install.

The original download link for BMT should also be updated later today with a installer that goes straight to v1.02.00. Sorry about this :frowning: .


#5

I was able to get v1.02.00 to successfully run by reinstalling from a “BigPharma_Installer” I had downloaded previously. (23 Aug date) - I should’ve just gone to HumbleBumble for latest.

Unfortunately that made me go through several download and update steps, rather than just go directly to the latest version, which makes more sense (to me). I think it was 1 V1 update and 2 patches.

I moved both Big Pharma directories (ProgramFiles(x86)/BigPharma and …/MyGames/BigPharma) and then ran the installer.

So now I’d have to move back the MODS, SAVES, SCREENSHOTS, etc. to get back to my former state.

Is there any file I can modify to FORCE Big Pharma to pull down the latest version and update? A file that stores what the current version is?
i.e. I want to move those 2 old folders back, modify some file, and try updating again so that I have all my old settings, etc but can get to v1.02.00.


#6

I guess I only needed to move the /MyGames/BigPharma folder back to get everything restored.

Would still like to know where the game stores current version.


#7

The version number is hardcoded. It has to be like this because the patching works on a differential system. You’ll notice that most patches are only around 2mb. This is because you are only downloading the stuff that has changed between versions. Because of this, it is impossible to jump directly to the latest version. However you always have the option of just redownloading the installer from humble/bmt. It is not up-to-date at version v1.02.

Like you say, the only thing you need to keep in terms of progress is …/MyGames/BigPharma. In fact you never have to move these throughout the whole process. Even when you uninstall the game it will leave the save games in place. So you can just uninstall, reinstall and it will seamlessly pick up from where you left off. Admittedly, it would be a lot nicer if the autopatching just worked!

Sorry about this. :frowning: