Bugs, Suggestions, and Impressions


#1

Bugs/Glitches:

  • Supply from stockpiles is occasionally very slow… there are gaps between products being put out. (And there are waiting assemblies & plenty of product in the stockpile). Is this intended?

  • Occasional graphical glitches… e.g. the car sprite goes down a SE-facing conveyor belt, and 3 tiles before the turn to NE, the graphic turns to face NE, so it looks like it is sliding sideways for a couple of tiles. Another: overlapping resource conveyors get into curious Escher-like tangles :slight_smile:

  • Sometimes I cannot connect conveyors properly. Imagine two conveyors coming together at a right angle, unconnected at the corner. I drag one end to the corner. Next, I drag that corner to the left to connect it to the other conveyor, but it refuses to connect. I generally need to delete the conveyors and try to connect them in a different order.

  • Sometimes get graphical glitches when removing resource conveyor belts – e.g. extra right-angled supports where there used to be T-junctions.

  • Pressing Esc should cancel the item in hand. (Some it does, some not, specifically: resource conveyors, conveyors, research office, supply stockpile).

  • If you select a supply stockpile from the build menu, then click Demolish, a click on the ground will NOT demolish – it will place a stockpile. Once that is out of hand, the demolish ability kicks in.

  • Double fittings: Before researching Fit Engine Assembly, I placed the Fit Engine Assembly. After researching, I forgot to remove that Assembly, but put down all parts immediately before it in the production line. Cars stopped at each fitting place (Flywheel, Starter Motor, and Valves), and ALSO stopped at the Fit Engine Assembly, consuming parts from each fitting place.

  • The “Make Valves” item is missing from the Valves assembly menu.

Suggestions:

  • Would be nice to have a research progress bar near the time controls area.

  • Tiles under resource conveyors are hard to visualize (in a grid) on the base of the conveyor. (Was playing on the medium map with bright white/blue tiles). When it goes into conveyor-mode, I often find that I have clicked the wrong square to start out on. Maybe add a toggle for conveyor-mode to turn on and off instead of just switching when conveyor placement starts? (and/or ability to toggle the world grid lines?)

  • When dragging (car) conveyors, the window for the fitting area pops up as you reach the next machine. (Maybe toggle this off when holding conveyors in hand?)

  • For setting up stockpiles, it would be nice if the Fitting Areas had a list of ALL the products they require. Would be even better to allow a copy/paste function to copy desired products to a stockpile, as well as required values for 1 assembly. (Similar to Factorio’s Copy assembler to requester chest function).

  • Pressing Esc should close the build menu if nothing is selected.

  • Suggest persistent items in hand: instead of just placing one fitting station, I would like to click on the ground again to place another. (Useful for building parallel lines of assembly).

Impressions:
I played a few hours tonight and am REALLY enjoying the game. The research into machines for every fitting means constant redesign of the factory, (in a good way!). The only real caveat is the cost of machinery – maybe just charge a “movement fee” of $500 instead of cutting the refund in half. (This somewhat inhibits redesign). I’m enjoying exploring all the different ways of doing things – importing to stockpiles, manufacturing components, etc.

One thing I would like request – line graphs for expenses over time. There’s a thrill when you manage to research Seat Manufacture, and it would be sooooo satisfying, after you place the manufactury, to see that Components cost go down :-). These kinds of line graphs were some of my favorite things to observe & track in SimCity, (2k, 3k, 4).


#2

Thanks, loads of awesome reports and suggestions. Working through a big todo list right now… :smiley: