Bullet Textures on a Mac Not Working?


#1

[code][config]
unlockcost = 0
lockable = 0
armour_penetration = 50
blasttexture = “turret_blast_red.png”
category = “WEAPONS”
classname = “SIM_BulletWeaponModule”
color = 3
cost = 213
crew_required = 12
damage = 50
description = “The primary pulse cannon of the Omega Class.”
fire_interval = 50
salvo_interval = 5500
salvo_size = 4
guiname = “EA OCD Main Pulse Cannon”
height = 9
hitpoints = 150
icon = turret_ecm_vee1.png
min_range = 190
max_range = 1250
name = “EA Omega Class Destroyer Main Pulse Cannon”
optimum_range = 620
powerconsumed = 20
shield_penetration = 55
size = “CRUISER”
sound = data/sounds/swarm_gun_08.ogg
soundvolume = 1.0
speed = 7
tracking_speed = 2.0
turret_sprite = “Cr EA OCD_Pulse_Cannon”
turretsize = 0
weight = 10
width = 10.0
slot_type = TURRET
uisortpos = 30500
restricted = “earth alliance”
bullet_texture = Flare1.png

[dataitems]
0 = cost,DECIMAL
1 = weight,DECIMAL
2 = hitpoints,DECIMAL
3 = powerconsumed,DECIMAL
4 = max_range,DECIMAL
5 = damage,DECIMAL
6 = fire_interval,INTEGER
7 = tracking_speed,DECIMAL
8 = shield_penetration,DECIMAL
9 = armour_penetration,DECIMAL
10 = crew_required,INTEGER
11 = optimum_range,DECIMAL
12 = min_range,DECIMAL
[/code]

That is what I have…can’t seem to get it to work. I have changed size, tried different texture files, changed from png to dds(I couldn’t get engine glows to work until I changed the txt file to engineglow.dds even though the file is a .png ), I have moved the line around in the code, ramped up the size…Am I missing something? I have looked over the tutorial several times, and it seems pretty straight forward?


#2

Assuming your PNG file is the game variety, is the Mac path to your file: mas/[modname]/data/bitmaps/fx/turret_blast_red.png ?

Next I’d look at turret_sprite = “Cr EA OCD_Pulse_Cannon”. Is it defined correctly in mas/[modname]/data/races/[modname].txt? You need the matching suffix in that definition. For example,

[turrets]
Cr EA OCD_Pulse_Cannon = [variable_name].dds,turrets_[modname].png,X

For what it’s worth, Mac’s can use DDS files. A couple other longshots might be:

Is name = “EA Omega Class Destroyer Main Pulse Cannon” unique?
It’s a long name, maybe character limit?
Spaces can be weird cross-platform. Usually best to avoid them in game code items, use an underscore “_” instead.

Your file posted looks correct tho. Will a different texture work? try using an existing game blasttexture. If that works (or not), you’ve narrowed down the issue.

Good luck


#3

Unrelated, but noted above - it’s a good idea (and traditional) to stick to lowercase letters and underscores for the internal names of things. The user never sees these anyway.


#4

The weapon emplacement itself works, and I get the standard game supplied rectangle in this case purple texture, but I can not seem to get it to override. I edited this particular image, but have done the same with a beam weapon texture and it worked.


#5

Tried renaming the file(all lower case, all lower case with .dds), quote marks, no quote marks…still no joy.


#6

As i do not have the mac version of GSB i do not know the answer to this.
The current mac version of GSB is what exactly ?

Reason why i ask is because the Bullet Texture is a recent addition to GSB.

(if the Mac version can run the Parasites DLC then it should have the custom bullet, AOE, Return to sender enhancements)


#7

Ver 1.54

Parasites is not available for mac yet (realized that AFTER I bought and downloaded the PC version by mistake.)…I posted a question asking if/when it would be but haven’t gotten a response yet. But this probably means I am not slap happy stupid in this case:D


#8

Nope, not in the slightest.

I have been following this thread for awhile but couldn’t think of any other logical reason other than the ones previously mentioned by the friendly members of this forum, as to why your hitting the problem (as your coding was spot on.) Then i realised that there is a chance that the Mac version may not have yet rolled out all the latest features that GSB on the PC version has.

The down side is that if my guess is correct, the Mac version will not have as of yet:

  • Flak weapon
  • Return to sender beams
  • MaxSim Plasma

RedMarbleGames has a member profile here in the forums. It couldn’t hurt to send them a PM as well as an email asking the question again (nicely of course).


#9

That’s the answer. I searched the files, “SIM_BulletWeaponModule” is not part of the Mac version (afaik). Good call.


#10

PM’ed RedMarble and they hope to have it (Parasites) done Very Soon:) happy dance


#11

That is good news :slight_smile:


#12

Well Parasites for Mac is out, but apparently GSB for mac should Auto update when it opens and my copy NEVER has. So I have version 1.54, Parasites requires version 1.58, so the expansion didn’t work initially, I had to delete the “Last Stand” order in the deployment file. Bullet textures still isnt’ working, AND I went ahead and purchased the Campaigns pack, and without a serial it doesn’t work. I bought my original copy of GSB from the App Store, I got the original 4 expansions from Red Marble, they didn’t work…so RMG sent me a new install with all the expansion packs, and I either didn’t get the serial, or never did get one.

Heck I even had to install Parasites a piece at a time, like a mod. I am in contact with RMG…it is just frustrating that non of this is working right.

Can you play campaigns without the serial at all?

Sorry for the rant.


#13

RMG has really good service. Again I was sent a dl link for a new full version 1.58, so I had to reinstall and all that jazz.

Now I have to figure out how to image my bullet textures so that they show up correctly.