Campaign Crash after retreat


#1

I was playing the campaign beta when the game crashed.

This is what happend:

  1. I attacked Kasheemun
  2. I lost all ships but 2 (ca. 15% of my fleet HP)
  3. I clicked retreat
  4. The countdown was not finished when I lost 1 of the 2 last ships
  5. When the game was about to return to the campaign view, the game crashed

I suspect that 2 things triggered at the same time: retreat and fleet below 10%, and the game couldn’t decide… But I may be wrong.

If it helps, those are the last lines in the file …\My Games\GratuitousSpaceBattles\campaignprogress\GAMENAME\debug.txt

Begin AIFightBattleThread **Choosing opponent at Kasheemun fleet cost is 9656.603516 GetFleetByLocation at 6 Fleet found existing ai fleet (gsb: 4629508) re-used GetFleetByLocation at 6 Fleet found End AIFightBattleThread Version: Full 1.52 Player retreated Campaign Fleet 14 Deleted Campaign Fleet 15 Deleted Moving victorious ai fleet (gsb: 4629508) to Kasheemun Campaign Fleet 15 Deleted


#2

I keep getting crashes when I retreat AND my fleet get below 10% while the countdown is running.

This time my fighters could retreat but my last cruiser got destroyed while the countdown was running.

**Choosing opponent at Argoshka fleet cost is 11009.737305 GetFleetByLocation at 34 No fleet found Opponent GSB chosen: 4631532. Popularity was 0 Downloaded Challenge File : C:\Dokumente und Einstellungen\MYUSERNAME\Eigene Dateien/My Games/GratuitousSpaceBattles/web/challenges/4631532.gsb Clearing enemies database entry for encounter 34 Adding new fleet from gsb 4631532 to 34 End AIFightBattleThread Version: Full 1.52 Player retreated Campaign Fleet 12 Deleted Moving victorious ai fleet (gsb: 4631532) to Besustine Campaign Fleet 12 Deleted

I see that both crashes has the a similar debug text, the game deletes 2 times the same fleet, here Campaign Fleet 12 Deleted.
Is this causing the crash? Because you cannot delete 2 times the same fleet, when you delete it 1 time, the second time it’s not there anymore?! I’m guessing.


#3

I have another problem, i cannot delete campaigns, when I click Delete the message box appears and I confirm with Yes, but nothing happens. I can however delete campaigns manually in the \My Games…\campaignprogress\ folder.

Both problems are based on the fact that GSB sometimes cannot delete files and folders in \My Games\ , so I suspect it’s a permission issue.

But I really don’t know how it’s possible, I’m sure I have writing permission (see also info below). Anyone has an idea? I have another game, that uses the \My Games\ folder, Company of Heroes (CoH), but I don’t have any problems with CoH.

[size=85]Hardware:

  • Intel Core 2 Duo E6400 (2 x 2,13 GHz)
  • 2 GB RAM
  • NVidia GeForce 7900 GS (256 MB)
  • Free disc space, >100GB drive C:\ (System drive), >100GB drive G:\ (Games drive)
  • Screen resolution 1680x1050

Software:

  • Microsoft Windows XP, Media Center Edition, Version 2002, Service Pack 3, German
  • My user account has administrator rights
  • Avira AntiVir (Antivirus Software), problems persist when disabled
  • Windows firewall, problems persist when disabled
  • No other security software installed

GSB related:

  • Playing GSB version 1.52
  • GSB is installed at G:\Gratuitous Space Battles\
  • Campaign progress is saved at C:\Dokumente und Einstellungen\USERNAME\Eigene Dateien\My Games\GratuitousSpaceBattles\
  • GSB freshly installed
  • No GSB mods (I did a fresh GSB installation after suspecting mods causing issues)
  • Tried running GSB with/without Visual Themes deactivated
  • Tried running GSB in Windowed/Fullscreen mode
  • Tried setting GSB affinity to only 1 core[/size]

#4

I’m investigating these issues right now. When you go to the folder that the game tries to delete ( a subfolder inside /my games/gratuitous space battles/campaignprogress, if you right click the folder it’s trying to delete, and select properties is the ‘read only’ box empty? no files in there should be read only, but I’m just curious as to if that might explain it.
(I cannot replicate the deletion bug on any of ym PCs :()


#5

The folder has the checkbox only half checked… i don’t know exactly what it menas (see picture).


The files in there are not read only (box is empty), I verified them all.



#6

I’m having related problems that seem to be snowballing.

Running GSB ver. 1.52 fullscreen on XP SP3, on a Q6600 with an ATI 5870. Purchased all expansions on Steam EXCEPT Nomads and Campaign, which I purchase directly from Positech.

After initiating a battle that gave me a progress bar that just froze, I had to force close GSB using Ctrl Alt Delete. My campaign was corrupted I guess, because I got an “invalid campaign!” error. Btw, the frozen progress bar has happened multiple times. Problem DLing the enemy fleet maybe?

Now I’m on my 5th campaign, which I’m praying doesn’t crash… They generally seem to happen during transitions, usually when I’m about to start a battle or am finishing one.

I can’t delete the campaigns savegames, which has been mentioned in this thread. I’ll try to do it manually. I also can’t delete any of my older ship designs, because they’re being used in the old invalid campaigns which I can’t delete. :slight_smile:

LOVE LOVE LOVE campaign, HATE HATE HATE crashing all the time.

Note: Ran the “Verify Game Files” thing on Steam, which told me I had to redownload 8 files. Didn’t say which, and didn’t tell me how. Gonna try to reinstall the whole shebang tomorrow, I guess.


#7

Deleting campaigns now works for me thanks to patch 1.53. Crash after retreating, if a lot of my ships get destroyed, still there. New since patch 1.53 also sometimes crash after winning, see http://positech.co.uk/forums/phpBB3/viewtopic.php?f=21&t=5833#p41030.


#8

Sadly have to add myself to this “list” of people having issues with this. In the Campaign mode if I retreat mid-battle, GSB crashes to the desktop… every time :frowning: Latest patch, game and all DLC packs bought and installed off the vendor purchase page (not through Steam). Main game works just fine…

Faulting application name: GSB.exe, version: 0.0.0.0, time stamp: 0x4d07b182
Faulting module name: GSB.exe, version: 0.0.0.0, time stamp: 0x4d07b182
Exception code: 0xc000000d
Fault offset: 0x001612aa
Faulting process id: 0xdb0
Faulting application start time: 0x01cb9ed113067ab8
Faulting application path: D:\Gratuitous Space Battles\GSB.exe
Faulting module path: D:\Gratuitous Space Battles\GSB.exe
Report Id: 0cd76f18-0ac6-11e0-90b2-000a3a8160e7

Any suggestions, guys? :-o


#9

Game still crashes with version 1.54 after retreating. This way the campaign is easier, because it doesn’t save the last turn and I can try a better strategy next time…
However, I would prefer that the game doesn’t crash.
After crashing, I always check the file debug.txt and the only “strange” thing I see is that it always deletes 2 times the same fleet (here Campaign Fleet 97 Deleted).

Version: Full 1.54 Player retreated Campaign Fleet 97 Deleted Campaign Fleet 115 Deleted Campaign Fleet 108 Deleted Moving victorious ai fleet (gsb: 4640718) to Arcadama Campaign Fleet 97 Deleted


#10

Don’t worry about the deletion being mentioned twice, that’ a red herring. I’m still trying to pin down why this happens, and replicate it happening on a dev machine.


#11

I have to add another report of this bug. But I’ve got it down to a little more reproduceable.

I’ve got a scout frigate that I use to see what the enemy fleets are. I only send that one ship to the enemy world. Once the battle starts, I retreat to save the ship.

What I’ve found is that if the ship is destroyed after I hit retreat, the failure dialog shows up, but when I dismiss the dialog, the game crashes to the desktop. (If I had to guess, I’d say that it’s trying to retreat a non-existent fleet, and thereby crashing on a null pointer)

In case it helps, I’m playing swarm, v 1.54. The only thing unique about my setup (I think) is that I’m using XP tablet edition. Is there any other information that would be useful? Would a save-game help?


#12

I think it’s fixed!!!
I’ll be uploading a patch for the game tommorow, and that should fix this issue… It was a bit evil to track down, but I have someone who could reproduce it who says the fix has worked for them.
That will become version 1.55


#13

I look forward to this patch propagating to the Mac version–I can’t finish a campaign, because the crashes eventually seem to lead to a corrupted campaign file. . .

RC


#14

I’ve sent the code to the mac guys immediately, so hopefully this will have a quick turnaround.
Cheers


#15

Thanks for patch 1.55, it seems to fix the issue also for me! I played a few battles in the campaign and it never crashed so far. It’s a lot more fun to play without the crashes…