Cannot register online


#1

Hey, just got the game, when I try to register, it crashes with the following error:

SIM_SERVER: Failed to open script response:…\src\SIM_Server.cpp 197

I’m running Windows 7, not out of disk space, no other issues. (I can play fine, just not register)


#2

This is an internet connection issue.
It can’t connect tot he server basically, so it’s likely that a firewall (maybe windows own firewall) is blocking the program. Just allow the game to go through and it will be ok.


#3

What port is it trying to use? I allow everything outbound through the firewalls I have sitting in front except port 25, so it’s probably the default Windows 7 firewall.


#4

Usually, when this stuff happens on my PC, (which i have since lost) when i go back to desktop, i usually get a window asking me if i want to block, unblock, or be asked later if i should block something. in this case, GSB. when it happens again, simply choose unblock.


#5

Yeah, I’m not getting that option. It simply pops the error, and crashes to desktop. If it was asking me to approve something, I’d allow it for sure.


#6

dang. sorry!


#7

Can you email me any files that the game has created in this folder:

MyDocuments\My Games\GratuitousSpaceBattles\web

that end in .html

email them to cliff@positech.co.uk.
There may not be any at all, in which case, either email em that or tell me here :smiley:
I’m trying to work out if the game isn’t hittinbg the server, or failing to open the files the server sends back. it’s almost always the case that its the game failing to hit the server.
If you download the demo, can the demo see the list of challenges? If it can’t then you definitely cannot connect to the server. It uses the default html web port (80) so shouldn’t be blocked.


#8

I figured it out, the port 80 got me on the right track. This was the issue:

I use Firefox as my web browser, but I used to use IE. When I was using IE, I had a web proxy I was going through, but that web proxy doesn’t exist anymore. Firefox isn’t configured to use the proxy, so web access worked fine, but I’d never bothered to switch IE back to direct connection.

GSB must have been looking at the IE proxy settings for its Internet access, because once I set IE to direct connection, GSB had no issue at all.

Thanks all for your help.


#9

Thats good news. GSB doesn’t specifically assume IE, but in windows the IE settings are the global system settings that affect any application that uses the WinInet API, which GSB uses.


#10

A-ha! I was having the same issue http://positech.co.uk/forums/phpBB3/viewtopic.php?f=21&t=3200 , but I was too lazy to debug it further. Now, Your post reminded me that IE on my current machine is f’d up, but I don’t care as I use Firefox. Fixing the proxy settings on IE fixed my issue also.