Can't Delete Campaign Ship Designs


#1

I had a campaign called “Test 2 Feds”, which I deleted. As far as the campaign itself is concerned, that campaign no longer exists (it doesn’t appear on the main campaign menu as an option to load). However, the ships I created for it still appear in the Ship Designer, both within the campaign and normally. But in neither case can I delete them.

When viewed in the “Load” screen of the Ship Designer, the X to delete these designs is grayed out, whether I’m in the campaign or not. Also, I can’t overwrite them. When I try to save a new design with the same name, whether I’m in the campaign or not, I’m told I can’t use the same name because that name is already being used in a campaign.

So, I have tried starting a new campaign named “Test 2 Feds” and deleting it. But still those same old designs survive.

I have also gone into My Documents\My Games\GratuitousSpaceBattles\campaignprogress and found a Test 2 Feds\fleets folder containing the offending designs. I have tried deleting these files and folders manually, but that causes another problem. Once I do this, I am unable to change races at all, so I’ve had to restore these files. And still I have the unwanted designs cluttering up the Ship Designer.

So, what to do? Thanks.


#2

Whoops! Never mind, I fixed it.

I made a mistake. When I tried to start and then delete a new campaign of the same name, I was using the wrong name. I was calling the new campaign “Feds Test 2” instead of “Test 2 Feds”. Using the right name and deleting that campaign removed the restriction on deleting the unwanted designs. Now they’re gone. Yay!

Still, there’s the issue of an incomplete campaign deletion that led to the problem in the 1st place.