Can't get new race ships


#1

I’ve got all the expansion packs but I hadn’t played the game since I bought them. Today I decided it’d be fun to start playing again and I noticed that I must have reloaded the game or something because everything was locked in Fleet HQ. So I went to an old backup file I had of GSB and copied the files out of the game folder and pasted them into the current game file. I’ve got everything back, but when I go to the “Races” tab at Fleet HQ, there’s only Alliance, Empire and Rebel races to choose from. In the “Ship Hulls” tab, everything is unlocked, but the ships from the new races aren’t even visible, but checking ship design they’re grayed out on the list.

Anyone had this problem before or have any ideas on how to fix it?


#2

I want to say your install.txt file isn’t updated properly, but I’m not entirely sure. Open that, and please post what it says.


#3

Where would I find that file? I just checked the GSB game folder and I don’t see any text documents.


#4

Well first of all, your GSB folder should look something like this:



And inside the data folder there should be an installs folder. Any DLC/mods should have a .txt file there.

If you think you may have messed up installation, and you’re not quite sure what to do, you may want to just uninstall the game and clear any remaining folders then reinstall GSB and all expansions/mods. I believe all save data is located elsewhere and should be unaffected. (May want a confirmation.)


#5

My game is a Steam download, im not sure if that’s the reason I can’t find the folder you’re talking about or not.


#6

are you sure you don’t just need to scroll down on the races tab? If everything is from steam, then if you cant see the races then they are not installed.


#7

The path should be: program files/Steam/steamapps/common/gratuitous space battles/data


#8

Yeah it just shows the three races, I mentioned above. I still have access to the Parasites DLC, but no options to unlock the other frigates, fighters and cruisers. It’s really really weird.


#9

did you buy all the expansion from steam too?


#10

Yessir I did lol, please don’t shun me xD I’m really looking forward to the next Xpac too, so I wanna get this solved now before it’s released.


#11

[size=10]SHUN THE NONBELIVER (why don’t you people let me do strikthroughs)[/size]

have you tried reinstating, you cant honestly tell me it takes more than 10 minutes to download a 2D game that’s built using images, and gif type-style imadges


#12

True but then i have to unlock everything again and do all the battles and stuff to unlock everything in fleet HQ, I’ve had to do it twice already, I don’t know if I have third time in me lol


#13

and that’s where using notepad comes in handy, what you’d have to edit i’m not sure ask one of the moders
but basically you’re debate is
ships i cant earn or modules i can earn, you decide which is more important


#14

Well the save data is saved in the My Games folder - separately from the program data - and it’s persistent, so uninstallation has no effect on it. (But you can easily back up that folder if you’re cautious)


#15

No that’s fine, it’s just more likely in this case that it is a steam issue, rather than one at my end. I suggest just renaming that \my documents\my games\gratuitous space battles folder and trying again, because thats the only data outside-of-steam installed files the game ever writes. It sounds like steams isn’t installing the DLC correctly, but only for you…


#16

If it’s a steam install issue, you can try this

Right click on the game in steam library, then go to property -> local file, click Verify Integrity of Game Cache.