Can't get this game to work :(


#1

Don’t get me wrong, I think this game is a true stroke of genius from Cliff… too bad I got it to run only 2 or 3 times… first the offline bug (game would not start when I was not connected to the internet), then the select hull bug (game would crash when I tried to change hulls in ship design screen), and now it won’t even start anymore (seem it cannot find a file named “race” or something… tried to uninstall and reinstall multiple times, to no avail. So I decided to remove it completely from my hard disk.
Anyway I’m happy to have contributed to the development of this little masterpiece (by buying it!).
Oh by the way, I have win Vista 32 bit and can’t wait to get this crappy SO off my computer…

I think I’ll wait for the release version and hope for the best.


#2

Hi. What version of the game did you have. The latest one shouldn’t exhibit any problems like those, even on vista (I develop on vista 32).
If you try reinstalling the game from scratch and still have problems, email me and I’ll help sort it out. (cliff@positech.co.uk)


#3

Hello Cliff,

I have tried a clean install of version 1.15 (deleting even the positech games folder after uninstall). I use Impulse, since I bought the game from them (shame on me!). Sadly, it didn’t work…


#4

Do you have the latest drivers for your video card? Are there any errors written by the game to its \debugdataz\errors.txt file?


#5

Ok I updated drivers and reinstalled from scratch… the game seemed to work fine until I registered my code on the online services; after that, it would crash when launching offline. The change hulls problem seemed to be solved. I don’t know if it’s useful to you, but here are the debug reports:

----DEBUG FILE----
Windows Vista detected
GSB Debug File. App version Beta 1.15
Desktop resolution is 1920 x 1080
Initialising Direct3D
Initialising global vertex buffer
creating render targets
success in initialising 3D
Checking for application update
Initialising Sound Engine
Initialised Sound System with 512 channels

Finished Initialising Sound Engine
IERROR: Internet: HttpSendRequest() Failed [12007]
Initialising Direct Input
Acquire


9/10/2009 - 17::22 - D3DERR_DEVICELOST
9/10/2009 - 17::22 - Flip


Initialising 3D Engine
Driver : nvd3dum.dll
Description : NVIDIA GeForce 9600M GT
DeviceName : \.\DISPLAY1
About to Create 3D Device with width: 1920 and height : 1080
Checking For Shader Support
NumSimultaneousRTs:4
hal_caps.PixelShaderVersion >= D3DPS_VERSION(2, 0)
Finished initialising 3D Engine
Initialising Render target of 512 X 512 rt_ship
rt_ship
Initialising Render target of 2048 X 2048 rt_offscreen1
rt_offscreen1
Initialising Render target of 2048 X 2048 rt_offscreen2
rt_offscreen2
titlescreen2048.bmp

I think I’ll reinstall again without registering to the online services of GSB for now… I’ll keep you posted. Thank you!


#6

That D3DERR_DEVICELOST is the problem: the video card disappeared while the program was using it. This is normally a nasty error, which would be something like the video card crashing.

I found this post which mentions it happening sometimes if a video card is overclocked, if the program’s resolution isn’t the same as the desktop resolution, or if the program loses focus while starting (such as when Vista switches to the non-Aero mode). If any of these might apply to you, perhaps try to avoid them and see if that fixes the problem.


#7

that error is also raised if you lock the PC, among other things:

virtualdub.org/blog/pivot/entry.php?id=269


#8

Thanks to all for the suggestions, I think I solved the video card bug, but the game still crashes when I launch it offline (but only AFTER I register my code to the online challenge services). On a clean install without registering online, it seems to work like it should.

Thanks everyone!