Can't launch game (Steam version)

Hi, I just purchased Democracy 4 on Steam and cannot get the game to launch

When I hit the green play button, it turns blue for a few seconds as if the game is starting but no windows are launched, I can’t see any activity in my take manager either, and then the button goes back to green.

I’ve verified files, reinstalled, and tried installing on both my SSD (E drive) and HDD (C drive).

Have looked at threads and tried common fixes like disabling antivirus - switched off windows defender but no luck and not super keen to have no antivirus running anyway :confused:

I do sometimes have issues launching games because my display is set to 1600 x 900, could that be an issue?

debug info below:

[9:12:12:406]- ----DEBUG FILE----
[9:12:12:406]- Windows 7 detected
[9:12:12:406]- Game version: 1.18
[9:12:12:406]- Failed to open file: C:\Users\Phil\Documents/My Games/democracy4/mod_status.ini : 2
[9:12:12:406]- GBufferedFile failed to open file [C:\Users\Phil\Documents/My Games/democracy4/mod_status.ini]
[9:12:12:837]- Setting Color palette
[9:12:12:837]- Updating BG shader
[9:12:12:837]- BG shader updated
[9:12:12:837]- Saving options
[9:12:12:838]- Options saved
[9:12:12:838]- Color palette set
[9:12:12:840]- Desktop resolution is 1600 x 900
[9:12:12:840]- Loaded Config: 1600x900@0 [windowed]
[9:12:12:846]- GEngine::Init Engine mode: 1600x900
[9:12:12:846]- GEngine::Desktop mode: 1600x900
[9:12:12:846]- Matching desktop res
[9:12:12:846]- Calling SDL_CreateWindow: 1600x900@0 [fullscreen]

1 Like

Have you tried killing the Steam.exe process in Task Manager> Processes? That helped me in the past when games would get stuck on the steam page.

But what you have seems to be similar to what a guy in a different thread has, the same files don’t load. So I’m doubtful my easy solution will actually be what solves it.

I got it working - only thing I changed was I had my monitor plugged into my integrated graphics rather than my graphics card by mistake.

Since I swapped them over, it works fine.

The Steam terminating is a good trick - I did try just a hard restart of the PC, which does the same, but all good now anyway!

Oh, that’s interesting. I’m glad you’ve got it working!

Maybe let the guy in this thread know what you did, since he has the exact same error message! It could be what he needs to do