Can't update


#1

Hi,

I used to have v1.28 which would not update (of course I couldn’t really tell because I couldn’t find the current version number on the website, only here in in a forum thread).

Then a read a thread that suggested rerunning the installer and that should get things going again. But that just put me back to v1.23, and still no updating. So at some point it must have updated.

Then I reset my calendar ahead. Still no updating.

None of my other programs have any trouble reading the internet. Still I’ve turned off windows firewall (if a firewall is a problem then GSB should provide some kind of usefull feedback rather than just mutely sitting there like everything is fine – besides, i get the challenges refreshed, why would an update be any different?). And still no update.

So, how do I update GSB? (something as basic as updating should have a redundant manual process in cases where auto-update mysteriously fails to work – twiddling with the OS date to trick the program isn’t really an acceptable solution).


#2

If the game fails to connect it may write some data to error fiels in
\program files\gratuitous space battles\debugdata
Howevere, the game will never try to connect online unless you have put in your serial number and picked a username on the ‘online’ screen in the game. have you done that?
Cheers,


#3

Serial number says it is valid, and my username has been accepted. Looking at text files in debugdata i don’t see anything that seems related to a failed update attempt.

I am using Windows7, the windows firewall is off, and this machine has no other firewall software. I do seem able to download new challenges, so GSB is able to send and receive some data.


#4

when it downloads new patches it sticks them here:
\my documents\my games\gratuitous space battles\patches,
Has it maybe downloaded them there, but something ahs blocked launching the updater? If so, you just need to run the latest one there (version 1.36).
Its possibly some security settings could be preventing the game calling an xternal program to run.


#5

Ok, finding the running the file manually did work. But even after the update the Order expansion still wouldn’t install (which was the original problem that revealed the update problem). After much poking around I learned that I had to manually move the installed files to a different location. So there are still no real solutions – I’ve just learned a couple manual hacks to bandaid things together. Now I realize that you are a small independent game developer, but given how much you charge, I don’t think this is acceptable.


#6

You dont have to manually move any files anywhere, at any stage. The installer should put every file where it needs to be. It does this, unless there is some setting or software on your PC which physically prevents it installing or running files. Can you elaborate on how precisely it is going wrong, and what fiels you have moved from one location to another?