Changing Races


#1

Today, I attempted to change races. After clicking a race to change to, nothing happened. The game did not freeze, the button just didn’t respond. So I clicked a few more times. And a few more times, and then, it registered. Later, I tried again. Same problem. Clicked about 50 times for 1 click to actually register. Anyone else have a similar problem?


#2

I have in fact had this problem. Usually it just affects one race at a time (“You can change to any race you want! Except that one.”) and for some reason it happens mostly to the Federation and Tribe (or perhaps those just happen to be the ones I want most of the time it gets squirrelly).

I have not found any consistency in either the problem or possible solutions. Restarting the game always makes it stop doing that for a while, but sometimes it’s just a matter of coming at the “select race” screen from a different point (either from the mission selection screen or from the deployment screen).


#3

Restarting it fixed it. However, it restricted to no classes besides the one already picked. I’m just curious as to what causes this.