"Could not find installed copy of Democracy 3"


#1

I’m trying to install the social engineering expansion pack I just bought (directly from the Positech website, through BMT micro orders). I’m on a Mac. I have tried leaving Democracy 3 in the applications folder, putting it in the downloads folder (with the expansion pack), and putting both together in a different folder.


#2

Hi, I think you already emailed me, but if not, drag and drop the downloaded file onto the running game (or the games icon).


#3

Hi Cliff;

I’m running into this same problem. I downloaded both the social engineering and extremism DLCs today. I tried to install these two DLCs and they would not install. Searching online for information I ran into this post. I am running version 1.284 of Democracy 3 on a Mac. I have the .dmg files downloaded. I start the game and then drag the .dmg onto the icon like your post says, but nothing changes in the game. I have tried to restart the game several times to see if this makes a difference, but it doesn’t. Any suggestions? Thanks for all that you do.