[Crash] 1.23 - "Fight" and "Save" cause CTDs in Challenges


#1

The game is from a beta upgraded today to full 1.23 with the automatic game update.
Running on Windows XP SP2, 4GB Ram, 120GB free space on hard disk and NVIDIA GTX 260 (896 Mo).
Resolution is 1920x1080.

==================================================

I can play the game normally in Battles.

When playing challenges, everything seems fine until I click on “fight” or “save”.
If I click on Fight, I have a Crash to Desktrop (CTD).
If I click on Save deployment, I can choose a save name, but it then causes a CTD.
This happens whether there is or there isn’t a ship deployed.

Here is the excerpt from the /debugdata/errors.txt, which concerns the four last crashes :

(with the three following, I tried "Save Deployment:)

4/11/2009 - 16::50 - Assertion failure:filename:…\src\GUI_DeploymentControlPanel.cpp,linenum:146,build:Full 1.23
4/11/2009 - 16::57 - Assertion failure:filename:…\src\GUI_DeploymentControlPanel.cpp,linenum:146,build:Full 1.23
4/11/2009 - 16::57 - Assertion failure:filename:…\src\GUI_DeploymentControlPanel.cpp,linenum:146,build:Full 1.23

(with the last one, I clicked on “Fight”)

4/11/2009 - 17::1 - Assertion failure:filename:…\src\GUI_DeploymentControlPanel.cpp,linenum:146,build:Full 1.23


#2

This is a problem saving files to disk. I’m not sure why that would be specific to challenges though, unless they are challenges relying on modded content that you do not have installed? Failing that, it could be a file permissions problem (not running as admin?) as it sounds like it’s not disk-space related.
Does this happen with all challenges?


#3

This is the same problem that i am having in this thread. viewtopic.php?f=21&t=3549

and yes every challenge


#4

Do either of you have any internet security or anti-spyware stuff running? Theoretically these could be preventing the game downloading the files or opening them in this case, or a firewall or other similar program could prevent them actually being downloaded to your PC. (the challenges get physically written to your disk).


#5

I’m having the same error, using Windows 7.
I let the program have administrative access and allowed it through Windows Firewall, but still experience the same crash:
5/11/2009 - 11::0 - Assertion failure:filename:…\src\GUI_DeploymentControlPanel.cpp,linenum:146,build:Full 1.23


#6

I’ve emailed you,
Cheers


#7

Can we get some for of mod management to allow for challenges requiring modpacks to be flagged as such (and perhaps even a “download mod” facility so you can get mods from the challenge screen if a URL is provided?)

I guess at the moment mods are created by manually altering existing files, if it was moved away from that to different versions of the core files that could be switched between it would probably be much more robust.


#8

I’ve had the same issue and at first I thought it was challenges that were modded, since a few did work. However today it kept on happening with challenges I could play beforehand or even after the crash. I didnt change any firewall (zonealarm) or admin settings. Also on one challenge with like over 100k worth of honor and 1k worth of crew it crashes everytime.

A different error, which could (small chance) somehow impact the bug being discussed here.
6/11/2009 - 5::51 - Turret mapping not found [turret_plasma_v4] ==> [empire]:…\src\SIM_Race.cpp 214
6/11/2009 - 6::13 - Assertion failure:filename:…\src\GUI_DeploymentControlPanel.cpp,linenum:146,build:Full 1.23

Impulse version, winxp.


#9

I’ve had one user fix this by allowing GSB through the windows firewall (in my experience, that’s not necessary but maybe that depends on your settings) and another user spotted that this happens if the challenge is for a scenario that is not unlocked yet. Is that the case here?


#10

Neither is the case. If it occurs like yesterday again. I will try to figure out why.


#11

well it occurred like 5 times today, which is okay compared to number of successful games (over 25). I still don’t know why it occurs, but after the crash I can immediately try the challenge again and it would usually work. Just now tried a challenge on defend casp. crashed 3 times on it and worked 4 times. The crashes didn’t occur in a row.


#12

I am having this problem as well. I can’t fight or save in any challenges at all.


#13

and with the exact same error message listed above?
This is after you have already played a mission in singleplayer on that map?


#14

I got a “Gratuitous Space Battles has encountered a serious error and needs to close” Microsoft error report message.

I unlocked all the maps and it works fine now though, apart from some challenges crashing the game because I don’t have certain modded ships used in other players formations.


#15

I actually unlocked and played all non survival scenarios to impossible before even trying the challenge mode, so its nothing to do with unlocking. At the same time its occurring on the same challenges that sometimes work and sometimes don’t, so its not related to the challenge being a modded challenge.

I have been getting new errors in the last two days.
6/11/2009 - 6::20 - Assertion failure:filename:…\src\GUI_DeploymentControlPanel.cpp,linenum:146,build:Full 1.23
6/11/2009 - 19::48 - Assertion failure:filename:…\src\GUI_DeploymentControlPanel.cpp,linenum:146,build:Full 1.23
7/11/2009 - 1::36 - Turret mapping not found [turret_plasma_v4] ==> [empire]:…\src\SIM_Race.cpp 214
7/11/2009 - 1::49 - Assertion failure:filename:…\src\GUI_TitleBar.cpp,linenum:25,build:Full 1.23
7/11/2009 - 1::49 - Assertion failure:filename:…\src\GUI_TitleBar.cpp,linenum:25,build:Full 1.23
7/11/2009 - 1::49 - Assertion failure:filename:…\src\GUI_TitleBar.cpp,linenum:25,build:Full 1.23
7/11/2009 - 2::52 - Assertion failure:filename:…\src\GUI_TitleBar.cpp,linenum:25,build:Full 1.23
7/11/2009 - 3::0 - Assertion failure:filename:…\src\GUI_TitleBar.cpp,linenum:25,build:Full 1.23
7/11/2009 - 4::12 - Failed to find current wave:…\src\SIM_SurvivalMode.cpp 145
7/11/2009 - 14::48 - SIM_SERVER: Download GSB file failed:…\src\SIM_Server.cpp 447
8/11/2009 - 3::30 - Assertion failure:filename:…\src\GUI_DeploymentControlPanel.cpp,linenum:146,build:Full 1.23
8/11/2009 - 4::58 - Assertion failure:filename:…\src\GUI_TitleBar.cpp,linenum:25,build:Full 1.23

As you can see theres a gui error occurring and not only when I hit fight in the challenge deployement screen. However this doesnt bother me too much. Only bothersome when it crashes after setting up a massive fleet and losing it all (can crash at save).


#16

Are you using any modded files? This sounds like there are some ships with no name (or an infinitely long name) or some other quirkiness causing those errors.


#17

Hi, I just purchased the game yesterday and I’m getting erratic CTDs when I try to play certain challenges. I’m running a new installation of GSB without any mods running on Windows XP. It was downloaded from BT Micro yesterday.

Attempting to play HJFudge’s challenge ##,4486593,HJFudge,all,“Federation class Frigates and Fighters…THE RECKONINGZ!!!11!”,0,10,83,3.4,3.6,“Battle above Edyai IX”,2009-10-18,“Federation” results in a consistent crash to desktop with these messages in errors.txt:

11/11/2009 - 22::3 - Assertion failure:filename:…\src\GUI_DeploymentControlPanel.cpp,linenum:146,build:Full 1.23
11/11/2009 - 22::7 - Assertion failure:filename:…\src\GUI_DeploymentControlPanel.cpp,linenum:146,build:Full 1.23
11/11/2009 - 22::10 - Assertion failure:filename:…\src\GUI_DeploymentControlPanel.cpp,linenum:146,build:Full 1.23

I tried to play a number of other challenges yesterday with mixed results. Some of them worked normally and some of them resulted in CTD while logging the same assertion failure to errors.txt. Currently these challenges work normally on my machine:

##,4483425,Salien,all,“No shields? No problem!”,0,116,427,2.40741,2.82716,“The Emerald Nebula”,0000-00-00,""
##,4483414,Salien,all,“Ready for a pounding?”,0,72,307,2.63492,2.79365,“The Multari Gas Giant”,0000-00-00,""
##,4483293,zyzyx,all,“See if you can beat this fleet deployment!”,0,87,281,2.95455,3.74242,“Defend Caspian IV”,0000-00-00,""
##,4491807,Scalu,all,“Can you face the might of the wimps!?!”,0,2,6,3.5,4,“Defend Caspian IV”,2009-11-11,“Alliance”

I played and beat the first three of these challenges last night and the results were recorded in the the challenge history window. However when I play one of the challenges now and quit right away (to see which challenges work), my attempts are not recorded in the challenge history.

So I decided to backup My Documents\My Games\GratuitousSpaceBattles and start with a fresh game folder, thinking that a clean set of settings might solve the problem. However when I try to play any of the challenges with my clean settings I get a CTD with these errors:

11/11/2009 - 22::24 - Assertion failure:filename:…\src\GUI_DeploymentControlPanel.cpp,linenum:146,build:Full 1.23
11/11/2009 - 22::24 - Assertion failure:filename:…\src\GUI_DeploymentControlPanel.cpp,linenum:146,build:Full 1.23
11/11/2009 - 22::25 - Assertion failure:filename:…\src\GUI_DeploymentControlPanel.cpp,linenum:146,build:Full 1.23
11/11/2009 - 22::26 - Assertion failure:filename:…\src\GUI_DeploymentControlPanel.cpp,linenum:146,build:Full 1.23

So it’s pretty clear the crash is related to something in My Documents\My Games\GratuitousSpaceBattles… Could this be related to certain ships or pieces of equipment not being unlocked? Anyway I just want the crashes to go away so I can play my new game. :slight_smile:

Edit: Okay, I think I’ve found the problem. It’s not related to unlocking equipment but to unlocking scenarios. When you create a new My Documents\My Games\GratuitousSpaceBattles\ folder, the My Documents\My Games\GratuitousSpaceBattles\deployments folder only contains two subfolders: tutorial1 and tutorial2. Copying the contents of my old deployments folder with it’s scenario and survival subfolders seems to have fixed the crash. It looks like the game is trying to save _temp_deployment.txt into folders that do not exist which causes it to crash.

So creating folders for each unlockable scenario, for example: survival1, survival2 and scenario1 through scenario11 in My Documents\My Games\GratuitousSpaceBattles\deployments should solve the problem. After creating the scenario11 folder, HJFudge’s challenge now works correctly for me.


#18

No modded files at all. This is a clean impulse installation.


#19

This is currently a known problem that is fixed in the upcoming patch version 1.24