Crash after 1.61 update [Solved]


#1

after the game updated itself to 1.61 today it keeps crashing whenever I to go to the fleet HQ with the following error:

7/12/2012 - 15::43 - Failed to find race:…\src\SIM_Race.cpp 136

I was using several mods with new races (starwars, unity, something with p…corp) so i suspect its some sort of incompatability introduced with the new patch?


#2

Hi, I assume it’s you who emailed me? Here was my emailed reply:


#3

renaming the userfolder and reinstalling to a new folder fixed it, now lets see if I can re-add the mods

edit: ok i re-added the praetorian industries mod, and the error is back


#4

The problem is due to the Praetors mod using an incorrect name the restriction code for modules.
In the past a typo when restricting a module would only make the weapon disappear from that race (which was useful)

But in version 1.61 - Cliff has given the modders the ability to lock down weapons to multiple races - therefore any typo will now cause an error because the game can not find the “non existent” race.

In other words - Praetors is gonna have to patch his game to make it compatible with v1.61
In the meanwhile, have a look at the prae_commercial_aliance_pulsar - its restricted to aliance (which does not exist)
if you change it to alliance the mod should now work.
(unless another mod has a similar problem)


#5

eeeeeeeeeek, another thing to fix for v1.1, thanks god i’ve not uploaded it yet…

I just hope thats the last game-crashing error :B


#6

I am getting the same error message when I go to the fleet HQ.
I have tried changing the name from aliance to alliance, but a module already exists.
What would be the next step to solve this?

Thanks Darkstar.


#7

Sorry - I don’t understand the question.

Just as a reminder - your changing
restricted = “aliance”
to
restricted = “alliance”


#8

It’s ok, Problem is solved.
I uninstalled the Praetorian Industries mod (Sorry Praetors! Maybe you can fine tune the spelling in the next version) and everything is working properly again. It seems that there is no room for spelling errors with the new update.


#9

Excellent :slight_smile:

That is correct.
From what I understand because we now can restrict weapons to multiple races :slight_smile:
(I think its worth it)


#10

Glad to have found this.

However is anyone else experiencing a crash when drones come up to a dreadnought?


#11

May I suggest that any further problems with this mod are best discussed in the thread for the mod . . .


#12

Seconded, most strongly. Warfighter67, this subforum is meant for support requests directly related to crashes and other weird behaviour within the vanilla game.

For problems with any form of modded content, post your request for help directly in the thread pertaining to the mod in question. If you have mods active within your GSB install, and a problem pops up later, the vast majority of the time it is the mods which are causing the crashes, and not the official game content. Thanks.