Crash after battle


#1

Clicking on the button to go to the info screen after winning a battle, I got the following error:
Error 41: Please contact tech Support:…\src\GUI_ButtonBase.cpp 110

Edit: And now when I start the game I get…
Error 41: Please contact tech Support:…\src\Game.cpp 242

Edit again: debug for second error, pastebin.com/d463a74bf


#2

Just got this same error. Investigating other threads to see if there is an answer


#3

Same here…

Now how could we all get this bug exactly at the same time?


#4

did you just d/l the build like 15 minutes ago like I did?


#5

I got the same error, game just doesn’t work anymore. =/

img515.imageshack.us/i/errorsv.jpg/

I even tried uninstalling, deleting everything including additional folders the game creates and still same error. If there’s a solution to this somewhere please post it here.


#6

This. Extremely suspicious anyone? /tinfoil hat


#7

Nah, I downloaded it this morning…


#8

I downloaded it about 5 or so hours ago. It was playing decently after turning off sound and some other fixes, and then I randomly got this error while designing ships. I came right here to post about it and found this thread with the exact same error.


#9

So weird. Downloaded this morning (U.S. time; about 14 hours ago), ran it for a few minutes, then went to work. Been playing since I got home (an hour or two), and then got this exact same thing, with these exact symptoms (crashed after a battle, now starting the game crashes it). If this happened to all of us at the same time, it HAS to be something with the online integration, right? It’s trying to access some server somewhere to look for updates or whatever, and that server is down? Just a theory.


#10

That, or maybe he’s able to push updates silently, and he pushed something buggy?


#11

Well, I’m going to use the time to boot into xp and open up some of the bitmaps in photoshop…


#12

I’m getting the exact same errors. Here’s a detailed description of events in case it sheds any light:

  1. Pre-ordered/downloaded beta build about half an hour ago.
  2. Launched game - no issues. Poked around in options, didn’t need to change anything (it auto-detected my default resolution, nice!).
  3. Started first battle - didn’t see difficulty selector buttons (they were there, but blank).
  4. Added a a few Gazelle frigates, and one of the Tiger cruisers. All default ships, nothing edited. Set fighters to escort new cruiser.
  5. Started battle. Watched it. Lost horribly. Conceded defeat.
  6. Poked around post-mortem screen - nothing out of the ordinary. Clicked Main Menu button.
  7. Game crashed. Got above errors.
  8. Re-launched game a few times. Always crashed on launch, always got one of those errors.
  9. Uninstalled (no folder remained, so presumably it’s completely gone) and reinstalled GSB.
  10. Still crashes on launch, same errors.

Oh, and I hadn’t entered my serial number yet - I hadn’t tried the online option at all, if that makes any difference.