Crash after install Democracy 3: Electioneering


i’ve a problem with the new DLC.
After a new Game (USA, default settings except no turn limit) the game crashes before each election.

The crash happens at my Workstation (fresh installation) with Windows 7and my Gaming PC (old Installation) with Windows 10.
I don’t use any Modifications except all DLCs.

The autosave.xml are empty (0 Bytes) after each crash.

What information do you need also?

Hi, this should be fixed now. We had some problems initially but the game has been patched. Make sure you are running the very latest version. If in doubt, re-download the game using the original download link in the purchase email.

Hi - I’m having the same issue. I’m running on OS X. If I disable the Electioneering mod, the game will run. Otherwise, it will crash each time.

is this a copy from the mac app store. The mac app store version is not updated yet, although we expect it to be updated this week (we are waiting for apple to ‘approve’ our update… :()

Thanks for the quick reply Cliff. No, I bought it off of the website. I ran the patcher on my version of the game and it’s up to date, but for some reason electioneering doesn’t work.

what version does it now say on the top right of the screen, and what symptom error do you get? does the game work ok without electioneering installed (for example on a totally fresh new game).

The top right says 1.14. I open the game, click to start a new game and right after I select the country the game crashes with an error message that says “Error Occurred: An unexpected error occurred.” It gives me the option to send the bug report or dismiss. However, when I sent the bug report, I received a bounce back saying the email was wrong.

If I disable the electioneering mod, the game will play fine.

Here is the bug report that is generated:

“Assertion failure:filename:/Users/urkle/Projects/HIB/Positech/democracy3/code/game/src/SIM_Override.cpp,linenum:47,build:1.14 – ptarg”

This is word for word the same error I have on the same OS and Democracy Electioneering version.

Hi Cliff - I’m still having issues and I have re-downloaded the game from the email I received after I bought the DLC. Do you know what the issue is or how I can fix this?


I’m having the exact same problem on mac…could we get some help ?

So I guess i just bought a game I cannot play…thanks for the support, really !!! :frowning:

I’m having the exact same problem, help please…

You need the latest version of the game to support electioneering. If you are having problems re-download and reinstall the game using the original download link when you purchased the game.