Crash on Launch


#1

When I try to start the game, a window opens for it, but it immediately throws up an error message:

GSB.exe has stopped working.

If I go into compatibility options, it recommends running the game as compatible for Windows XP (service pack 2). The game still won’t run, but this time I get the following error message:

Failed to find race:…\src\SIM_Race.cpp130

I have installed the latest drivers for my card, reinstalled GSB and Direct X, and renamed the GSB folder.

I’m running this in Windows 7 at a screen resolution of 1600 x 900.

Any ideas?


#2

From what i can tell, its looking for another race.
have you installed a mod to GSB ?


#3

No, I haven’t yet, but I did get it fixed.

Turns out I’d confused things by exploding the size of on-screen text to make it easier for my tired old eyes to read. This apparently convinced GSB that my screen height was only 600. Decreasing text to normal size allows the game to run just fine. Having a great time with it now. Much thanks. :smiley:


#4

I am running Win7 in XP SP2 compatibility mode and I get the exact same error, except that the last 3 digits are 128 instead of 130. My screen resolution is 1440 X 900 and I have changed nothing and my system is very new with no apps other than drivers (dedicated game rig). I played the demo without a problem. I bought the full package and installed the main game, The Order, The Swarm, and the Tribe in that order, then patch 1.36 from Gamersgate. I have not attempted a piecemeal install which is what I will do next to determine if an expansion is at fault. There are no patches above 1.36 available at Gamersgate so if I need 1.38 that puts me in a bind.


#5

Installing all but the Swarm expansions seems to result in a viable build so I suspect this is a problem with the Swarm expansion. Can you guys push the latest patch to Gamersgate so that we can run the product too? :slight_smile:


#6

I’ve just updated gamersgate with version 1.38, but if you enter a username and serial on the online screen of the game, it will update itself to 1.38 on launch automatically.
Cheers,


#7

Hi,

I just wanted to let you know that I seem to have the same problem with the demo version. Just decided to test the game after reading the DLC article on Bit-tech by Cliff.

The game starts and shows the splash screen. After that it crashes with the following info:
Problem signature:
Problem Event Name: BEX
Application Name: GSBDemo.exe
Application Version: 0.0.0.0
Application Timestamp: 4bf51340
Fault Module Name: GSBDemo.exe
Fault Module Version: 0.0.0.0
Fault Module Timestamp: 4bf51340
Exception Offset: 001161cf
Exception Code: c000000d
Exception Data: 00000000
OS Version: 6.1.7600.2.0.0.768.3
Locale ID: 1035
Additional Information 1: 06ff
Additional Information 2: 06ff057dc5ec3753cb01ba5dc03df96e
Additional Information 3: b7bb
Additional Information 4: b7bbddcb4266b4213e52c003cbe7b6c4

Debug.txt content:
----DEBUG FILE----
Windows 7 detected
GSB Debug File. App version Demo 1.38
Desktop resolution is 2560 x 1600
Initialising Direct3D
Initialising global vertex buffer
creating render targets
success in initialising 3D
Initialising Direct Input
Finished Initialising Direct Input
Initialising Sound Engine
Initialised Sound System with 512 channels

Finished Initialising Sound Engine

I have a triple monitor system with a desktop resolution on 4960x1600 with a geforce 8800 gts 512 and a geforce 6200. Other than that the system should be quite ordinary and I haven’t fiddled with text sizes etc. The windows is a 64 bit version.


#8

Hi again,

My bad. Windows xp sp3 compatibility mode solved the problem.

Edit:
Perhaps I dismissed the problem a bit too hastily. The crash seems to happen on 80% of the game launches regardless of the compatibility mode.


#9

I hate to register just because I’m having a problem, but I’m also getting a crash on launch thanks to the game trying to find mod races that aren’t there anymore. Is there some way I can stop the game from looking for the mods in the first place? Reinstalling isn’t helping, and I’m not really eager to track down the mods again.

I bought the game through Impulse and am playing it in Windows XP, if that makes a difference.


#10

either

ditch the entire \mydocuments\my games\gratuitous space battles

folder
or…

ditch \mydocuments\my games\gratuitous space battles\ships

you might also (if you have an older version of the game) edit the

\Documents\My Games\GratuitousSpaceBattles\config.txt file to change the race, if the race was set to one that no lonegr exists.


#11

I didn’t know the game saved anything to My Documents. I went into the ships folder and deleted the specific ships that were causing the problem; now the game works like a charm. Thanks muchly.