crash on ship load


#1

After downloading 1.41, every time I hit ‘Load’ on the ship design screen gsb crashes


#2

Are there any messages displayed when it happens? If you don’t see any then try doing it again, and as soon as it freezes press alt + tab. This should force the window to change from the main GSB window, and you’ll be able to see any messages being displayed.

From my experiences crashes there are usually from ship designs that use modules that have been removed or changed.

If nothing is displayed there then post here whatever is in the debug files located at My Documents/My Games/GratuitousSpaceBattles/debug .

****************************** Edit *****************************
After patching my own one I am now crashing when I click on the ship design button from the main menu. There’s no error message that pops up when it crashes; however, there is an error txt file in the debug folder.
Here are the contents:
14/6/2010 - 16::54 - Assertion failure:filename:…\src\GUI_DesignLoader.cpp,linenum:313,build:Full 1.41

I’m running at 1920x1200 resolution.

I am able to access the ship designer from inside a battle setup without it crashing; however, as soon as I click the load button it crashes.


#3

Got the same thing happening here after patching.


#4

Looks like another patch is going to be pulled back…


#5

Gah, I’ll investigate

Edit: dang. So far can’t replicate this. Still investigating…

can you let me know what expansions you have installed.
Also, if you rename the \mygames\gratuitous space battles folder, then re-run the game, does it work ok? (just as a test)
Cheers,

also can you look for warnings or error in the \debug\debug.txt file. especially ones from the same time and date pertaining to not finding ships.

I need sleep right now but…

This error indicates basically that a ship design exists but the ship design could not be loaded. This could be that you have an entry for a ship design which references an expansion pack that is uninstalled. This is all very unlikely, but might help identify the bug.
If you have patched, please ensure the patch was installed to the right place. Actually go run the gsb.exe file from windows explorer inside the \program files\gratuitous space battles folder and make sure you dont suddenly have a patch of gsb installed in a different folder to where the actual game is installed. (just a theory).


#6

And since it’s not DL’ing the patch for me, I’d say it already has been.


#7

I will try to do a clean install sometime in the next day to figure out if it’s just something I installed.
Currently I have all expansions installed as well as my Tau’ri and Orbital Platform mods. At one time I believe I also had the original Star Wars mod installed, but I’m not sure if it was before or after my last clean install.


#8

I may have found the cause of the issue:
First I deleted the ships directory in the my documents section. That worked perfectly and loaded any designs made afterwards without a hitch. Next, I went and added my previous designs in groups of three at a time and it seems to have worked without crashing for all but a few. It was modded stuff mostly and one of the builds was a known invalid design when I tweaked weapon power requirements earlier - I just hadn’t bothered to delete it.
I was able to confirm this by making a design invalid on purpose (deleted a power core module) and got the exact same crash and entry in errors.txt
My suggestion is to either restart from scratch and rebuild your designs or add them in small groups and delete whatever causes the crash.


#9

it crashes on ship load for me to
i tryed fress instal (GSB folder deleted completly) but its the same

ed by me:
i’m on vista 64
i bought game and all 3 expansions of impulse

ed by my:
tryed same with vanillia game (no expansions just patch)
freezes just the same


#10

I figured out the problem for me. There were some ship designs i made in beta that at some point quit being able to load for whatever reason. Now instead of just not loading they caused HORRIBLE CRASHING. Just deleted them out of mydocuments\my games\gratuitiousspacebattles\ships and its all good.


#11

can we get the fix?
game is unpleyable as it is <_<


#12

Okay it crashes for me as well. Fresh install.

I just removed my ship designs and it works.

Copying back, only one design caused the crash - a fighter design I edited using the flaky hull editor.

Berny


#13

i dont have ANY design
its 100% fresh instal
also i dod not edin anything EVER


#14

Hi, so if you delete entirely the mydocuments\mygames\gratuitous space battles folder,
then launch the game, then click on ship design immediately, does it crash?
if so, please email me at cliff@positech.co.uk with the contents of the \mydocuments\my games\gratuitous space battles\debug
folder as attachments.


#15

Yep, it looks like deleting the GSB folder in My Games fixes the problem. Now my only question is what was changed in this last update that would cause it? Were any of the module stats changed?


#16

Nope, it looks like what has happened is that the previous versions would just ignore any ship designs that could not be loaded because they were invalid (ie: they were designed when you can add x modules to hull Y, and now you can’t). This new version doesn’t seem to handle them as well, hence the crash, which I’ll fix for the next build (although thats a way off now).
So the solution is to move all your ship designs out, as suggested, and copy them in until you spot the one thats invalid, but its very likely to be the oldest ones as the rules haven’t changed for ages.
No existing usable designs are affected, just ones that are effectively hidden because the game refused to load them.


#17

Theres no way of adding a “Hotfix” for this?


#18

It’s not really necessary since once you’ve fixed it yourself the first time it won’t happen again.


#19

still crashes after deleting GSB folder in my documents
mail sent
fix please

ed by me:
thx for fast reply
one of tutorial shops was corupted ^^
works now ^^


#20

Hi,

Just a confirmation about having, and easily manually fixing this bug.

I got the game a couple days ago from Impulse with all the expansions. Windows 7 64-bit.
I had played the tutorial and first scenario, had deleted one of the tutorial ships, and would get a crash anytime clicking the load button.

Glancing at the error file (debug.txt), I saw errors about a sample ship called federation gazelle, and about the tutorial frigate I had deleted. Manually removing the following two things solved the issue.

  1. I deleted my deployments subfolders from C: Users > Owner > My Documents > My Games > GratuitousSpaceBattles > deployments
    Note that the above path is Win7, and possibly one should substitue one’s user name instead of ‘Owner’.
    (I only had a couple deployments , and will revisit the levels later anyway, so no big deal at all.
    Probably I could have just deleted the ones that referenced the removed frigate)

  2. I deleted the gazelle ship text file in C: Program Files (x86) > Gratuitous Space Battles > data > sampleships
    Since it’s not loading anyway, and is only a tutorial / starting sample, no big deal. I likes my error files clean.

GSB is now happy. Load button works, very nice/convenient feature.
1.42 subsequently just arrived, and continues to be happy.

Many thanks for this thread, which pointed me in the right direction, and towards the error file.
Btw, enjoying the game a lot, very fun / fresh. Much appreciate the wit, and the general subtlety of the mechanics.


A mild miscellaneous side comment that a benign very small defect exists on patching on win7, where post-1.4.2 install it tried to continue on to autolaunch GSB and dies on a missing dll library. However this is entirely harmless, and GSB loads fine on next click/invoke. And I’ve seen it elsewhere (other games/executables) on win7, so I’m pretty sure it’s either the generic patcher/launcher generally vs win7, not your content/patching. Simply starting GSB proceeds fine, it’s something (generic?) about certain installer packages (Impulse?) and expectations of operating system helper dll libraries I think.

Did I mention I love this game.
Hotness.

I would kill to have some of the commentary during battles audiabled with vocals, btw, if it were varied and had an on/off option. I chuckle over it every now and again, just reading. Fun times…