Crash to Desktop when viewing voter groups


#1

Hi everyone…

I’m new here but I’ve encountered the following problem: It’s turn one after my first election win (yay) and I’m crashing to the desktop whenever I try and view the voter groups (from the centre of the screen). I seem to be able to do everything else just fine.

I’ve also skipped a few turns before I try and view the voters, but it’s still doing the same thing. The only other piece of info I can provide is that I saved game straight after I won the election, so I don’t know if this is due to the election or the save.

Thanks for your help,

Michael


#2

Hi there what version of the game is this? Menu screen top right will tell you. And do you have a save game that always does this when you load it in?
Thanks,


#3

It’s version 1.12, and yeah I have a save game which does it pretty consistently.

I can send it to you, with the “Windows Error Report” if you like?


#4

yes please, cliff AT positech…


#5

experiencing the same problem on 1.13

vista 32bit running in xp comp mode with visual themes disabled.

haven’t tried using a different save game yet


#6

Unfortunately that doesn’t help :frowning: I need a save game that can trigger it on one of my PCs :smiley:


#7

rapidshare.com/files/93009850/2.xml.html


#8

Thanks, I’m investigating it now.


#9

Gah.
Ok found it. Its to do with voter names. Fixing it will break old save games unfortunately :frowning:
But I’ll fix it right now.


#10

fixed in 1.14 patch. (AFAIK)


#11

great, thanks


#12

Hi. I’m having the exact same problem with a 3 days old version 1.15.
Running on 32-bit Vista
No mods installed and no files modified by me either

Hope this can be solved because the game is great.


#13

Gah…

I can fix this so it doesn’t crash trivially. and I’ll do that this weekend at the latest, but ideally, I need to work out why its crashing so I ensure I’ve fixed it correctly.
Something must be wrong with my previous fix for this bug in 1.14. Essentially what’s going wrong is this:

1)game is started and everyone is given Russian or Spanish or some other non standard name
2)game is saved, and each voter stores the id of their name (to save space)
3)game is loaded, and for some reason, standard names are initialised
4)voter asks for the translation of name 185, and game crashes as it only has 100 names.

The thing is, this should be fixed in 1.14. The game loads in the mission name, and initialises the right set of names. only if you edited the mission file between saving and loading should it be able to crash. Does this help anyone see what might have caused it? I’m assuming this isn’t hitting everyone or I’d be swamped with emails.
Feel free to send me any save games that do this, the more data the merrier.


#14

Cliffsky: Savegame sent to your email.
Hope it helps


#15

It did, I’ve found it, I’ll get it fixed today or tomorrow. Also, old save games will then load in ok. Every voters name won’t be 100% correct, but I’m sure that doesn’t really matter :smiley:


#16

Ok patched:

viewtopic.php?f=10&t=1334&p=7781#p7781

let me know if this has not fixed it


#17

Brillinant! That’s was quick.
Thanks a lot.

Do you make an update for the ingame autoupdate or how is it solved?

Is the savegame I sent broken after the patch?


#18

oooppss! Sorry. Didn’t read the whole thing.

Found it out

Savegame works perfectly now

Thanks