CTD upon startup


#1

Hello,
when I start the game it produces a black window with the caption “Gratituous Space Battles” and an error popup with the message “Failed to initialise 3D Engine:…\src\Game.cpp 288”.
Once I click on OK the game then crashes.
I am using Windows Vista Home Premium 64 bit Service Pack 2 on an early 2008 Macbook Pro with a NVIDIA GeForce 8600M GT graphics chip.
My desktop resolution is 1440 x 900.


#2

This is vista 64 running on a Mac? I didn’t even know you could do that, let alone if GSB would mind! Can you send me the files the game generates in its ‘debugdata’ folder to cliff@positech.co.uk
Cheers.


#3

I am using Bootcamp which allows me to dualboot to OS X and Windows.
The debugdata folder is empty (it used to contain three text files which were included in the installation so I deleted them and no new files have been created after I start GSB).


#4

I have managed to solve the problem.
The resolution in the prefs.ini was a weird combination (1039 x 768).
This happened because I first started the game in a window in the Parallels for Mac VM which I use when I don’t want to reboot to use Windows.
It then used the current window size and subsequently was unable to initialize the game.
The problem persisted even after a reinstall because the config folder was untouched by the uninstaller (you may want to make removing the game completely an option).
After changing the resolution to 1024 x 768 the game starts without any complaints.
It also works nicely in the VM which means I can play the game while using OS X.


#5

Thanks for posting your fix! I ran into the same problem (tried starting GSB while Parallels was in windowed mode). The good news is that it runs fine when Parallels is running fullscreen. A bit slower than running native w/ Boot Camp, but very playable.