D2 Crashes on Load


#1

Hello all

Just downloaded the demo to see if i could get this to work(even tried downloading previous versions) - tried lots of things but i cant seem to get it to work :frowning:

Specification : Samsung R700, on windows 7 64 bit … Nvidia 8400M GS Graphics card.

Tried setting the config to windowed mode, safe mode, 16 bit (if i choose 16 bit i get some Seriously crazy flashing!)
Tried setting it in compatability mode, doesnt seem to make any difference

Game gets to the main page, with music - Quit button is there, and the info in top right (demo 1.18 i think it was) However theres no other buttons and the mouse cursor is completely unmovable.

code----DEBUG FILE----
Windows Vista detected
releasing resources
writing global vars
releasing game subystems
releasing d3d
Clearing textured sprites
END DEBUG—
[/code]

codeInitialising Direct Draw
Forcing to safe mode, fullscreen not stable
Attempting windowed mode
Creating Context at 1024 768 16
Forcing Fallback Init
Attempting Fallback Init
Fallback init succeeded
Driver: NVIDIA GeForce 8400M GS \ Microsoft Direct3D Hardware Transform and Lighting acceleration capable device
VidMem: 1395 MB
Texture created : data/bitmaps\fonts\tahoma12.dds
tahoma12.dds
Texture created : data/bitmaps\fonts\verdana12.dds
verdana12.dds
Texture created : data/bitmaps\fonts\verdanabold16.dds
verdanabold16.dds
Texture created : data/bitmaps\fonts\arial16.dds
arial16.dds
Texture created : data/bitmaps\fonts\arialbold16.dds
arialbold16.dds
Texture created : data/bitmaps\fonts\arialbold20.dds
arialbold20.dds
Texture created : data/bitmaps\fonts\tahoma30.dds
tahoma30.dds
Texture created : data/bitmaps\title.bmp
title.bmp
Texture created : data/bitmaps\button.dds
button.dds
Texture created : data/bitmaps\button_h.dds
button_h.dds
Texture created : data/bitmaps\spark_red.dds
spark_red.dds
Texture created : data/bitmaps\spark2.dds
spark2.dds
Texture created : data/bitmaps\spark.dds
spark.dds
loadscreen.jpg
Release D3DEngine
Redundant calls/frame = 0.000000
Engine already released
[/code]

Also included is my config file:

[config] ColorDepth=16 IsWindowed=1 SafeMode=1 ForceFallback=1 build = DisableVerticalSynch=0

Seems radically small for a config file ? or is that just me ? :slight_smile: - any help much appreciated ! i really wanna get on and play :slight_smile:


#2

Hi, this is a windows 7 video driver issue. Getting newer drivers may fix it, but Democracy 2 uses directx7 and the nice people who constantly cram useless features into video card drivers no longer care about supporting it properly, so theres a chance they just wont ever release windows 7 drivers that wrk with older games correctly :frowning:
You can try running the game in compatibiltiy mode (right click the icon), for older versions of windows.

GSB and later games will use Directx 9


#3

Thanks for the reply mate,

Sadly compat mode doesnt work at all :frowning: just makes things worse

ill keep trying and wait and see if nvidia do something about it >.>


#4

Hi Cliff,

The full version’s not working for me either (Win7 x64 HP, 8800GTX, E6700), but it works fine on a friend’s Raddy-based Win7 x64 PC. I get much the same symptoms as Matt.

Have you had any feedback on whether the problem is limited to nVidia cards, or Win7x64/Nvidia combos? I’m considering sticking Vista back on my machine for now, at least until issues like this are solved. Hopefully.

Cheers!


#5

Im wondering if a game he has on his desktop has installed some old-compatable directx components that DX10 is missing by default ?

what other stuff does he have installed on the desktop you dont have? (you’ve sparked my curiosity) :slight_smile:

edit: i also am having the problem (error locking vb) as posted by someone here:
viewtopic.php?f=10&t=1558

nvidia 8800M GS - no overclocking etc. -Win7 pro x64, build 7600


#6

His rig is built as much for overclocking as it is for games, so it’d be fair to say that it’s highly customised - I wouldn’t really know where to start! But I’ve been playing around with the Win7 compatibility troubleshooter, and that tells me that the texture Tahoma12.dds is missing.

Incidentally, I tried all the drivers from version 185 to 191. No joy there. But I’ve also sent a support email to nVidia, so I’ll keep you posted.


#7

AFAIK this is happening for the most part with an nvidia win7 combo. Although I’m not sure exactly what driver versions and setups cause it :frowning:


#8

Nvidia’s response was fairly predictable: do a clean install, update the BIOS, check your hardware, yadda yadda.

I think the simplest solution (for me, anyway) will be to install a dual-boot with Vista 32. Then my PC will be a haven of democracy once more :slight_smile:


#9

ahhh nice i guess …
I dont want to purchase until i can play it on my laptop (sorry?!) i can force it upon my desktop but i want it on the lappy…

i guess ill keep my fingers crossed the next beta drivers fix something! (the ones im using still suck!)

Nevermind, and thanks for your input darth - much appreciated :slight_smile:

Any Driver version currently causes it atm cliff, see i thought the driver on x64 win7 was the same as x64 vista ? - in which case democracy will run on gtx260 but not a mobile gpu…