Democracy 3 DLC's are a dysfunctional mess on macOS.

So I, for the record, bought this game on the Humble Store, and these comments are about the DRM-free version from there.

The installer for the main game worked fine.

The installers for the first three DLC’s added the mod files to the application, but simultaneously made macOS think that it was corrupt. I knew the terminal commands to remove this flag, but really, requiring obscure sudo commands for running paid games is just ridiculous.

The last DLC, (Its the latest one, think it was electioneering) literally just gave me the mod file and left it up to me to manually find the mod folder inside the application and add it. After doing that, it worked, but I shouldn’t have to do that on paid DLC.

The Democracy 3 Africa installer was… nonexistent. The application was just there in my downloads folder instantly, unpacked and ready to run. I don’t really mind this approach (copying a program to the applications folder is simple enough, and not needed to run the software), but it does seem inconsistent.

After running Democracy 3 Africa, I immediately noticed that I had no DLC. I tried copying the DLC’s manually from the main game and dumped them in /Applications/ (there was no mods folder or anything that seemed like a replacement, so I just made one to test if that would work). This did not work, and I have yet to find a solution to this problem. I would like further assistance in this area. Oddly, the DLC icons do appear on the title screen (and remain there after removing the mods folder), but they neither show up in the mods section, nor are their features present when playing the game.