Democracy 3 segfaults on Linux 3.11 x86 - Needs STEAM??

Using Fedora 18 32-bit with the Linux Kernel 3.11.4-101.fc18.i686 and I just bought Democracy 3, installed the .sh without problems, but when I try to run the game, I get the following error before the grame segfaults.

[S_API FAIL] SteamAPI_Init() failed; SteamAPI_IsSteamRunning() failed. [S_API FAIL] SteamAPI_Init() failed; unable to locate a running instance of Steam, or a local steamclient.dll. Segmentation fault (core dumped)

Before buying, the website said that I do not need steam to play this game, and that is DRM free. So, is it just a bug of some sort, or do I need steam after all? A huge selling point for me was the lack of any of those DRM schemes, so I hope there’s a workaround to avoid having to install steam?

Hi, you definitely don’t need steam, but there may have been an issue with linux builds before today, we just rolled out a new version today, so please give that a try.

What graphics hardware do you have? and what version of Democracy3 did you download? And as Cliff stated, now the game doesn’t require Steam. And actually the latest full download has the Steam libs removed completely…


i’ve got the exact same problem. i don’t know where to download the updated game files, and the patch does not work either:

$ sh ./ Verifying archive integrity...Error in MD5 checksums: a6710f587b8eab8baec0050e38ae30f6 is different from a4b28ff5b24912ed8b0ddc1045d11b20

This means your download is corrupted… Please re-download the linux patcher. the MD5 of the 1.13 linux patcher file should be 9a51485147b3b08aafe63575080d544b (note: the MD5 you see above is just of the internal payload)

i’ve downloaded the patcher 3 times now… same result.

$ md5sum b8a1151ee3302b721358e6e6266360d3

Hmm… ok… I’ll check w/ Cliff to make sure the correct file is on his server…

A 1.14 patch is now be available… can you try intsalling that patch and see if it resolves your issue? It also may be worth just re-downloading the full installer.

$ ./ Verifying archive integrity...Error in MD5 checksums: ede07d79ab2fe4425caf50e45be0654f is different from a4b28ff5b24912ed8b0ddc1045d11b20

seriously now…

Yeah, something is up… I just checked the mac + linux patches up there and all of the linux ones are broken. I’ve emailed cliff about it.

so. i really appreciate that you support linux and … stuff, but could you at least give some basic support here? give me a humble bundle code or something, so i can add it to my collection and download it from there.

Can you re-download a full installer from cliff’s site? The patch installers are still broken for some reason I’ll be working with cliff this week to get those fixed.

how do i do that?

Oh, this is the right thread! :slight_smile:

I am having similar problems. Just bought the game from HumbleBundle, changed permissions and tried to run the .sh-file

./ Verifying archive integrity...Error in MD5 checksums: 821f7ab1be09812c07cb77340b90eca6 is different from a4b28ff5b24912ed8b0ddc1045d11b20

Those checksums does not even match the one on the HumbleBundle download page.
Tried to download the file multiple times and run it, but the same thing happened.

There appears to be an issue with failing due to a checksum error. I renamed the directory with my old v1.13 installation that contained some mods (I thought the patch might be failing because of this). Then I reinstalled with the original v1.13 and tried to patch to v1.14:

fskmh@workstation:~> ./ 
Verifying archive integrity...Error in MD5 checksums: ede07d79ab2fe4425caf50e45be0654f is different from a4b28ff5b24912ed8b0ddc1045d11b20

I obtained the patch from the support link ( Could you please fix this because I have the flickering display issue and I am using the proprietary nvidia driver, so it’s not the nouveau driver that’s causing this issue.

P.S. Just purchased D3A and was disappointed to notice that it only became clear afterwards that there was no Linux version (there was no warning beforehand that D3A was not supported on Linux). Yes, it will probably run in wine, but not terribly impressed.