Democracy3.exe Has Stopped Working

Recently, when I clicked on Democracy 3 it loaded up but when I try start a game or load a game an error message pops up saying Democracy3.exe has stopped working. I cannot play Democracy 3 anymore and it’s pretty stink considered I’ve played 52 hours of the game and it’s the main game I play.

This is on Steam by the way.

I’ve uninstalled the game and reinstalled it and it doesn’t work.

I’ve deleted my mods and it doesn’t work.

Please help!

No help? Seriously, it’s one of the only games I play and it’s unplayable now.

I have the same problem, but this message appears virtually every time i go to a quarterly report.
I also purchased from steam however i have no and have never installed any mods for this game.
I’ve also tried uninstalling and reinstalling and the game to no success.
does anyone have any ideas how to fix this issue?

Having the same issue, just purchased a few hours ago, the game ran the first time I tried it, however when I try and start a new game, select the country, and click “play” I get the same message.

Using version 1.22, downloaded from Steam.
Disabled mods to no avail.
uninstalled, reinstalled, verified game integrity.

Yeah. I’m also getting the same issue over here.

Same issue here.

Problem signature:
Problem Event Name: BEX
Application Name: Democracy3.exe
Application Version:
Application Timestamp: 562e66ff
Fault Module Name: Democracy3.exe
Fault Module Version:
Fault Module Timestamp: 562e66ff
Exception Offset: 0017459d
Exception Code: c0000409
Exception Data: 00000008
OS Version: 6.3.9600.
Locale ID: 1033

Same problem here and I have only just bought the game, I have tried all the fixes that have been suggested on the forum and no joy…
I think it should be said…“Buyer Beware!”